rescue: Rewrite virt-rescue in C.
[libguestfs.git] / tools / Makefile.am
index 651daf9..1803049 100644 (file)
 include $(top_srcdir)/subdir-rules.mk
 
 tools = \
-       df \
        edit \
        list-filesystems \
        list-partitions \
-       ls \
        make-fs \
-       rescue \
        resize \
        tar \
        win-reg
@@ -42,27 +39,22 @@ bin_SCRIPTS = $(tools:%=virt-%)
 
 # Manual pages and HTML files for the website.
 
-# XXX Bug in automake?  If you list virt-df.1 explicitly, then it
+# XXX Bug in automake?  If you list virt-edit.1 explicitly, then it
 # builds and installs the man pages.  However if this is removed,
 # then the man pages are neither built nor installed.
-man_MANS = virt-df.1 $(patsubst %,virt-%.1,$(filter-out df,$(tools)))
+man_MANS = virt-edit.1 $(patsubst %,virt-%.1,$(filter-out edit,$(tools)))
 
 noinst_DATA = $(tools:%=$(top_builddir)/html/virt-%.1.html)
 
 virt-%.1: virt-%
-       $(POD2MAN) \
-         --section 1 \
-         -c "Virtualization Support" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         $< > $@-t && mv $@-t $@
+       $(top_srcdir)/podwrapper.sh \
+         --man $@ \
+         $<
 
 $(top_builddir)/html/virt-%.1.html: virt-%
-       mkdir -p $(top_builddir)/html
-       cd $(top_builddir) && pod2html \
-         --css 'pod.css' \
-         --htmldir html \
-         --outfile html/$<.1.html \
-         tools/$<
+       $(top_srcdir)/podwrapper.sh \
+         --html $@ \
+         $<
 
 # Tests.
 
@@ -74,9 +66,7 @@ TESTS_ENVIRONMENT = \
        LIBGUESTFS_PATH=$(top_builddir)/appliance \
        PERL5LIB=$(top_builddir)/perl/blib/lib:$(top_builddir)/perl/blib/arch
 
-TESTS = test-virt-df.sh \
-       test-virt-list-filesystems.sh \
-       test-virt-ls.sh \
+TESTS = test-virt-list-filesystems.sh \
        test-virt-make-fs.sh \
        test-virt-resize.sh \
        test-virt-tar.sh