regressions: Enable both tests for bug 576879 (not fixed).
[libguestfs.git] / test-tool / Makefile.am
index 510a42f..15a5c8f 100644 (file)
@@ -15,7 +15,9 @@
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
-EXTRA_DIST = libguestfs-test-tool.pod
+include $(top_srcdir)/subdir-rules.mk
+
+EXTRA_DIST = libguestfs-test-tool.pod run-test-tool-locally
 
 CLEANFILES =
 
@@ -28,6 +30,7 @@ AM_CPPFLAGS = \
 
 libguestfs_test_tool_SOURCES = test-tool.c
 libguestfs_test_tool_CFLAGS = \
+       -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        -Wall
 libguestfs_test_tool_LDADD = \
@@ -37,8 +40,6 @@ libguestfs_test_tool_helper_SOURCES = helper.c
 libguestfs_test_tool_helper_LDFLAGS = -all-static
 
 libguestfs-test-tool.1: libguestfs-test-tool.pod
-       $(POD2MAN) \
-         --section 1 \
-         -c "Virtualization Support" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         $< > $@
+       $(top_srcdir)/podwrapper.sh \
+         --man $@ \
+         $<