out-of-tree build: fix building library
[libguestfs.git] / src / Makefile.am
index cc01459..a5d7322 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs
-# Copyright (C) 2009 Red Hat Inc.
+# Copyright (C) 2010 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
 
 include $(top_srcdir)/subdir-rules.mk
 
+CLEANFILES = stamp-guestfs.pod
+
 generator_built = \
        guestfs_protocol.x \
-       guestfs-structs.h \
-       guestfs-actions.h \
+       guestfs.h \
        guestfs-internal-actions.h \
        actions.c \
        bindtests.c \
+       errnostring_gperf.gperf \
+       errnostring.c \
+       errnostring.h \
        guestfs-actions.pod \
        guestfs-availability.pod \
        guestfs-structs.pod \
        libguestfs.syms
 
-$(generator_built): stamp-generator
-
 BUILT_SOURCES = \
-  $(generator_built) \
-  guestfs_protocol.c \
-  guestfs_protocol.h
+       $(generator_built) \
+       guestfs_protocol.c \
+       guestfs_protocol.h \
+       errnostring_gperf.c
 
 EXTRA_DIST = \
        $(BUILT_SOURCES) \
        MAX_PROC_NR \
-       stamp-generator \
-       generator.ml \
        libguestfs.3 \
-       guestfs.pod
-
-# Rerun the generator if it has changed.
-# Git removes empty directories, so in cases where the
-# generator is creating the sole file in a directory, we
-# have to create the directory first.
-noinst_DATA = stamp-generator
-
-stamp-generator: generator.ml ../images/test.iso
-       mkdir -p $(top_srcdir)/perl/lib/Sys
-       mkdir -p $(top_srcdir)/ruby/ext/guestfs
-       mkdir -p $(top_srcdir)/java/com/redhat/et/libguestfs
-       mkdir -p $(top_srcdir)/csharp
-       cd $(top_srcdir) && ocaml -warn-error A src/generator.ml
+       guestfs.pod \
+       api-support/added \
+       api-support/README \
+       api-support/update-from-tarballs.sh
 
-../images/test.iso:
-       make -C ../images test.iso
-
-include_HEADERS = guestfs.h guestfs-actions.h guestfs-structs.h
+include_HEADERS = guestfs.h
 
 lib_LTLIBRARIES = libguestfs.la
 
-# This convenience library is solely to avoid compiler warnings
-# in its generated sources.
-libprotocol_la_SOURCES = \
-  guestfs_protocol.c \
-  guestfs_protocol.h
-
-libprotocol_la_CFLAGS =
+# This convenience library is solely to compile its generated sources with
+# custom flags.
+libprotocol_la_SOURCES = guestfs_protocol.c  guestfs_protocol.h
+libprotocol_la_CFLAGS = -Wall -Wno-unused -fno-strict-aliasing
+
+# Build the errnostring perfect hash code.  The generated code has lots
+# of warnings so we must compile it in a separate mini-library.
+liberrnostring_la_SOURCES = \
+       errnostring_gperf.c \
+       errnostring.h \
+       errnostring.c
+liberrnostring_la_CFLAGS =
+
+errnostring_gperf.c: errnostring_gperf.gperf
+       rm -f $@
+       $(GPERF) -t $< > $@-t
+       mv $@-t $@
 
 # From the libtool info file, with comments:
 #
@@ -115,31 +113,56 @@ libprotocol_la_CFLAGS =
 # 'libguestfs.so.0.$(MAX_PROC_NR).0'.
 libguestfs_la_LDFLAGS = -version-info $(MAX_PROC_NR):0:$(MAX_PROC_NR)
 
-libguestfs_la_LDFLAGS += $(VERSION_SCRIPT_FLAGS)libguestfs.syms
+libguestfs_la_LDFLAGS += $(VERSION_SCRIPT_FLAGS)$(srcdir)/libguestfs.syms
 
 libguestfs_la_SOURCES = \
        guestfs.c \
        guestfs.h \
-       guestfs-actions.h \
        guestfs-internal.h \
        guestfs_protocol.h \
        gettext.h \
        actions.c \
+       appliance.c \
        bindtests.c \
+       dbdump.c \
+       events.c \
+       filearch.c \
        inspect.c \
+       inspect_apps.c \
+       inspect_fs.c \
+       inspect_fs_cd.c \
+       inspect_fs_unix.c \
+       inspect_fs_windows.c \
+       inspect_icon.c \
        launch.c \
+       listfs.c \
+       match.c \
        proto.c \
+       virt.c \
        libguestfs.syms
 
-libguestfs_la_LIBADD = $(HIVEX_LIBS) $(LIBPCRE) $(LIBMAGIC) $(LTLIBTHREAD) ../gnulib/lib/libgnu.la
-
-# Make libguestfs include the convenience library.
-noinst_LTLIBRARIES = libprotocol.la
-libguestfs_la_LIBADD += libprotocol.la
+libguestfs_la_LIBADD = \
+       $(HIVEX_LIBS) $(AUGEAS_LIBS) $(PCRE_LIBS) $(MAGIC_LIBS) \
+       $(LIBVIRT_LIBS) $(LIBXML2_LIBS) \
+       ../gnulib/lib/libgnu.la \
+       $(GETADDRINFO_LIB) \
+       $(HOSTENT_LIB) \
+       $(INET_NTOP_LIB) \
+       $(LIBSOCKET) \
+       $(LIB_CLOCK_GETTIME) \
+       $(LIBINTL) \
+       $(LTLIBTHREAD) \
+       $(SERVENT_LIB)
+
+# Make libguestfs include the convenience libraries.
+noinst_LTLIBRARIES = liberrnostring.la libprotocol.la
+libguestfs_la_LIBADD += liberrnostring.la libprotocol.la
 
 libguestfs_la_CFLAGS = \
   -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
-  $(HIVEX_CFLAGS) \
+  -DGUESTFS_WARN_DEPRECATED=1 \
+  $(HIVEX_CFLAGS) $(AUGEAS_CFLAGS) $(PCRE_CFLAGS) \
+  $(LIBVIRT_CFLAGS) $(LIBXML2_CFLAGS) \
   $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
 libguestfs_la_CPPFLAGS = -I$(top_srcdir)/gnulib/lib
@@ -147,50 +170,34 @@ libguestfs_la_CPPFLAGS = -I$(top_srcdir)/gnulib/lib
 if HAVE_RPCGEN
 guestfs_protocol.c: guestfs_protocol.x
        rm -f $@-t $@-t2
-       $(RPCGEN) -c -o $@-t $<
+       $(RPCGEN) -c -o $@-t $(srcdir)/$<
        sed 's,\.\./\.\./src/,,' < $@-t > $@-t2
        rm $@-t
        mv $@-t2 $@
 
 guestfs_protocol.h: guestfs_protocol.x
        rm -f $@-t
-       $(RPCGEN) -h -o $@-t $<
+       $(RPCGEN) -h -o $@-t $(srcdir)/$<
        mv $@-t $@
 endif
 
 # Manual page.
-# guestfs-actions.pod, guestfs-availability.pod and guestfs-structs
-# are autogenerated.  There is no include mechanism for POD, so we
-# have to do it by hand.
 
 man_MANS = guestfs.3 libguestfs.3
+noinst_DATA = $(top_builddir)/html/guestfs.3.html
+
+guestfs.3 $(top_builddir)/html/guestfs.3.html: stamp-guestfs.pod
 
-guestfs.3: guestfs.pod \
+stamp-guestfs.pod: guestfs.pod \
                guestfs-actions.pod \
                guestfs-availability.pod \
                guestfs-structs.pod
-       sed \
-         -e '/@ACTIONS@/rguestfs-actions.pod' \
-         -e 's/@ACTIONS@//' \
-         -e '/@AVAILABILITY@/rguestfs-availability.pod' \
-         -e 's/@AVAILABILITY@//' \
-         -e '/@STRUCTS@/rguestfs-structs.pod' \
-         -e 's/@STRUCTS@//' \
-         < $< | \
-       $(POD2MAN) \
+       $(top_builddir)/podwrapper.sh \
          --section 3 \
-         -c "Virtualization Support" \
-         --name "guestfs" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         > $@
-
-# Check user doesn't try to do 'make all' or 'make check' as root.
-# https://www.redhat.com/archives/libguestfs/2010-April/msg00098.html
-
-all-local: checkroot
-check-local: checkroot
-checkroot:
-       @if [ "`id -u`" = 0 ]; then \
-           echo "*** Error: Don't run 'make' or 'make check' as root."; \
-           exit 1; \
-       fi
+         --man guestfs.3 \
+         --html $(top_builddir)/html/guestfs.3.html \
+         --insert $(srcdir)/guestfs-actions.pod:@ACTIONS@ \
+         --insert $(srcdir)/guestfs-availability.pod:@AVAILABILITY@ \
+         --insert $(srcdir)/guestfs-structs.pod:@STRUCTS@ \
+         $<
+       touch $@