Rewrite of main loop impl, start of FileIn/FileOut support.
[libguestfs.git] / src / Makefile.am
index 7fa17e0..9e3fdf8 100644 (file)
@@ -23,6 +23,10 @@ EXTRA_DIST += guestfs_protocol.x \
        guestfs_protocol.c \
        guestfs_protocol.h
 
+EXTRA_DIST += generator.ml
+
+include_HEADERS = guestfs.h guestfs-actions.h guestfs-structs.h
+
 lib_LTLIBRARIES = libguestfs.la
 
 libguestfs_la_LDFLAGS = -version-info 0:0:0
@@ -33,9 +37,9 @@ libguestfs_la_SOURCES = \
        guestfs_protocol.h \
        guestfs-actions.h
 
-libguestfs_la_CFLAGS = -Wall
+libguestfs_la_CFLAGS = -Wall -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"'
 
-if RPCGEN
+if HAVE_RPCGEN
 guestfs_protocol.c: guestfs_protocol.x
        rm -f $@-t
        $(RPCGEN) -c -o $@-t $<
@@ -45,4 +49,6 @@ guestfs_protocol.h: guestfs_protocol.x
        rm -f $@-t
        $(RPCGEN) -h -o $@-t $<
        mv $@-t $@
-endif
\ No newline at end of file
+endif
+
+CLEANFILES = *~