Rewrite of main loop impl, start of FileIn/FileOut support.
[libguestfs.git] / src / Makefile.am
index 566fa41..9e3fdf8 100644 (file)
@@ -23,7 +23,9 @@ EXTRA_DIST += guestfs_protocol.x \
        guestfs_protocol.c \
        guestfs_protocol.h
 
-include_HEADERS = guestfs.h guestfs-actions.h
+EXTRA_DIST += generator.ml
+
+include_HEADERS = guestfs.h guestfs-actions.h guestfs-structs.h
 
 lib_LTLIBRARIES = libguestfs.la
 
@@ -37,7 +39,7 @@ libguestfs_la_SOURCES = \
 
 libguestfs_la_CFLAGS = -Wall -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"'
 
-if RPCGEN
+if HAVE_RPCGEN
 guestfs_protocol.c: guestfs_protocol.x
        rm -f $@-t
        $(RPCGEN) -c -o $@-t $<
@@ -47,4 +49,6 @@ guestfs_protocol.h: guestfs_protocol.x
        rm -f $@-t
        $(RPCGEN) -h -o $@-t $<
        mv $@-t $@
-endif
\ No newline at end of file
+endif
+
+CLEANFILES = *~