Move guestfs(3) and guestfish(1) man pages into subdirectories.
[libguestfs.git] / src / Makefile.am
index 2e33c1a..7d9220a 100644 (file)
@@ -23,7 +23,10 @@ generator_built = \
        guestfs-actions.h \
        guestfs-internal-actions.h \
        guestfs-actions.c \
-       guestfs-bindtests.c
+       guestfs-bindtests.c \
+       guestfs-actions.pod \
+       guestfs-availability.pod \
+       guestfs-structs.pod
 
 $(generator_built): stamp-generator
 
@@ -36,7 +39,8 @@ EXTRA_DIST = \
        $(BUILT_SOURCES) \
        MAX_PROC_NR \
        stamp-generator \
-       generator.ml
+       generator.ml \
+       libguestfs.3
 
 # Rerun the generator if it has changed.
 # Git removes empty directories, so in cases where the
@@ -140,3 +144,29 @@ guestfs_protocol.h: guestfs_protocol.x
        $(RPCGEN) -h -o $@-t $<
        mv $@-t $@
 endif
+
+# Manual page.
+# guestfs-actions.pod, guestfs-availability.pod and guestfs-structs
+# are autogenerated.  There is no include mechanism for POD, so we
+# have to do it by hand.
+
+man_MANS = guestfs.3 libguestfs.3
+
+guestfs.3: guestfs.pod \
+               guestfs-actions.pod \
+               guestfs-availability.pod \
+               guestfs-structs.pod
+       sed \
+         -e '/@ACTIONS@/rguestfs-actions.pod' \
+         -e 's/@ACTIONS@//' \
+         -e '/@AVAILABILITY@/rguestfs-availability.pod' \
+         -e 's/@AVAILABILITY@//' \
+         -e '/@STRUCTS@/rguestfs-structs.pod' \
+         -e 's/@STRUCTS@//' \
+         < $< | \
+       $(POD2MAN) \
+         --section 3 \
+         -c "Virtualization Support" \
+         --name "guestfs" \
+         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
+         > $@