Experimental C# bindings.
[libguestfs.git] / src / Makefile.am
index 62a94c4..619f46e 100644 (file)
@@ -23,7 +23,10 @@ generator_built = \
        guestfs-actions.h \
        guestfs-internal-actions.h \
        guestfs-actions.c \
-       guestfs-bindtests.c
+       guestfs-bindtests.c \
+       guestfs-actions.pod \
+       guestfs-availability.pod \
+       guestfs-structs.pod
 
 $(generator_built): stamp-generator
 
@@ -36,7 +39,8 @@ EXTRA_DIST = \
        $(BUILT_SOURCES) \
        MAX_PROC_NR \
        stamp-generator \
-       generator.ml
+       generator.ml \
+       libguestfs.3
 
 # Rerun the generator if it has changed.
 # Git removes empty directories, so in cases where the
@@ -48,6 +52,7 @@ stamp-generator: generator.ml
        mkdir -p $(top_srcdir)/perl/lib/Sys
        mkdir -p $(top_srcdir)/ruby/ext/guestfs
        mkdir -p $(top_srcdir)/java/com/redhat/et/libguestfs
+       mkdir -p $(top_srcdir)/csharp
        cd $(top_srcdir) && ocaml -warn-error A src/generator.ml
 
 include_HEADERS = guestfs.h guestfs-actions.h guestfs-structs.h
@@ -112,7 +117,7 @@ libguestfs_la_SOURCES = \
        guestfs-actions.c \
        guestfs-bindtests.c \
        guestfs-internal.h \
-       guestfs-protocol.h \
+       guestfs_protocol.h \
        gettext.h
 
 libguestfs_la_LIBADD = $(LTLIBTHREAD)
@@ -140,3 +145,29 @@ guestfs_protocol.h: guestfs_protocol.x
        $(RPCGEN) -h -o $@-t $<
        mv $@-t $@
 endif
+
+# Manual page.
+# guestfs-actions.pod, guestfs-availability.pod and guestfs-structs
+# are autogenerated.  There is no include mechanism for POD, so we
+# have to do it by hand.
+
+man_MANS = guestfs.3 libguestfs.3
+
+guestfs.3: guestfs.pod \
+               guestfs-actions.pod \
+               guestfs-availability.pod \
+               guestfs-structs.pod
+       sed \
+         -e '/@ACTIONS@/rguestfs-actions.pod' \
+         -e 's/@ACTIONS@//' \
+         -e '/@AVAILABILITY@/rguestfs-availability.pod' \
+         -e 's/@AVAILABILITY@//' \
+         -e '/@STRUCTS@/rguestfs-structs.pod' \
+         -e 's/@STRUCTS@//' \
+         < $< | \
+       $(POD2MAN) \
+         --section 3 \
+         -c "Virtualization Support" \
+         --name "guestfs" \
+         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
+         > $@