Experimental C# bindings.
[libguestfs.git] / src / Makefile.am
index 1c0fa0a..619f46e 100644 (file)
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
-EXTRA_DIST = \
+include $(top_srcdir)/subdir-rules.mk
+
+generator_built = \
        guestfs_protocol.x \
-       guestfs_protocol.c \
-       guestfs_protocol.h \
+       guestfs-structs.h \
+       guestfs-actions.h \
+       guestfs-internal-actions.h \
+       guestfs-actions.c \
+       guestfs-bindtests.c \
+       guestfs-actions.pod \
+       guestfs-availability.pod \
+       guestfs-structs.pod
+
+$(generator_built): stamp-generator
+
+BUILT_SOURCES = \
+  $(generator_built) \
+  guestfs_protocol.c \
+  guestfs_protocol.h
+
+EXTRA_DIST = \
+       $(BUILT_SOURCES) \
        MAX_PROC_NR \
        stamp-generator \
-       generator.ml
+       generator.ml \
+       libguestfs.3
 
 # Rerun the generator if it has changed.
 # Git removes empty directories, so in cases where the
@@ -31,14 +50,23 @@ noinst_DATA = stamp-generator
 
 stamp-generator: generator.ml
        mkdir -p $(top_srcdir)/perl/lib/Sys
-       cd .. && ocaml -warn-error A $(srcdir)/src/$<
-
-guestfs_protocol.x: stamp-generator
+       mkdir -p $(top_srcdir)/ruby/ext/guestfs
+       mkdir -p $(top_srcdir)/java/com/redhat/et/libguestfs
+       mkdir -p $(top_srcdir)/csharp
+       cd $(top_srcdir) && ocaml -warn-error A src/generator.ml
 
 include_HEADERS = guestfs.h guestfs-actions.h guestfs-structs.h
 
 lib_LTLIBRARIES = libguestfs.la
 
+# This convenience library is solely to avoid compiler warnings
+# in its generated sources.
+libprotocol_la_SOURCES = \
+  guestfs_protocol.c \
+  guestfs_protocol.h
+
+libprotocol_la_CFLAGS =
+
 # From the libtool info file, with comments:
 #
 # |  1. Start with version information of `0:0:0' for each libtool library.
@@ -81,36 +109,65 @@ lib_LTLIBRARIES = libguestfs.la
 # Note that this scheme means the real library version will always be
 # 'libguestfs.so.0.$(MAX_PROC_NR).0'.
 
-BUILT_SOURCES = \
-  guestfs_protocol.x \
-  guestfs-structs.h \
-  guestfs-actions.h \
-  guestfs-actions.c \
-  guestfs-bindtests.c
-
-$(BUILT_SOURCES): stamp-generator
-
 libguestfs_la_LDFLAGS = -version-info $(MAX_PROC_NR):0:$(MAX_PROC_NR)
 libguestfs_la_SOURCES = \
        guestfs.c \
        guestfs.h \
-       guestfs_protocol.c \
-       guestfs_protocol.h \
        guestfs-actions.h \
        guestfs-actions.c \
        guestfs-bindtests.c \
+       guestfs-internal.h \
+       guestfs_protocol.h \
        gettext.h
 
-libguestfs_la_CFLAGS = -Wall -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"'
+libguestfs_la_LIBADD = $(LTLIBTHREAD)
+
+# Make libguestfs include the convenience library.
+noinst_LTLIBRARIES = libprotocol.la
+libguestfs_la_LIBADD += libprotocol.la
+
+libguestfs_la_CFLAGS = \
+  -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
+  $(WARN_CFLAGS) $(WERROR_CFLAGS)
+
+libguestfs_la_CPPFLAGS = -I$(top_srcdir)/gnulib/lib
 
 if HAVE_RPCGEN
 guestfs_protocol.c: guestfs_protocol.x
-       rm -f $@-t
+       rm -f $@-t $@-t2
        $(RPCGEN) -c -o $@-t $<
-       mv $@-t $@
+       sed 's,\.\./\.\./src/,,' < $@-t > $@-t2
+       rm $@-t
+       mv $@-t2 $@
 
 guestfs_protocol.h: guestfs_protocol.x
        rm -f $@-t
        $(RPCGEN) -h -o $@-t $<
        mv $@-t $@
 endif
+
+# Manual page.
+# guestfs-actions.pod, guestfs-availability.pod and guestfs-structs
+# are autogenerated.  There is no include mechanism for POD, so we
+# have to do it by hand.
+
+man_MANS = guestfs.3 libguestfs.3
+
+guestfs.3: guestfs.pod \
+               guestfs-actions.pod \
+               guestfs-availability.pod \
+               guestfs-structs.pod
+       sed \
+         -e '/@ACTIONS@/rguestfs-actions.pod' \
+         -e 's/@ACTIONS@//' \
+         -e '/@AVAILABILITY@/rguestfs-availability.pod' \
+         -e 's/@AVAILABILITY@//' \
+         -e '/@STRUCTS@/rguestfs-structs.pod' \
+         -e 's/@STRUCTS@//' \
+         < $< | \
+       $(POD2MAN) \
+         --section 3 \
+         -c "Virtualization Support" \
+         --name "guestfs" \
+         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
+         > $@