Fix small typo in a comment in src/Makefile.am.
[libguestfs.git] / src / Makefile.am
index f23464e..5f796a0 100644 (file)
@@ -128,12 +128,18 @@ libguestfs_la_SOURCES = \
        actions.c \
        appliance.c \
        bindtests.c \
+       filearch.c \
        inspect.c \
        launch.c \
+       listfs.c \
        proto.c \
+       virt.c \
        libguestfs.syms
 
-libguestfs_la_LIBADD = $(HIVEX_LIBS) $(AUGEAS_LIBS) $(LIBPCRE) $(LIBMAGIC) $(LTLIBTHREAD) ../gnulib/lib/libgnu.la
+libguestfs_la_LIBADD = \
+       $(HIVEX_LIBS) $(AUGEAS_LIBS) $(PCRE_LIBS) $(MAGIC_LIBS) \
+       $(LIBVIRT_LIBS) $(LIBXML2_LIBS) \
+       $(LTLIBTHREAD) ../gnulib/lib/libgnu.la
 
 # Make libguestfs include the convenience libraries.
 noinst_LTLIBRARIES = liberrnostring.la libprotocol.la
@@ -141,7 +147,8 @@ libguestfs_la_LIBADD += liberrnostring.la libprotocol.la
 
 libguestfs_la_CFLAGS = \
   -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
-  $(HIVEX_CFLAGS) $(AUGEAS_CFLAGS) \
+  $(HIVEX_CFLAGS) $(AUGEAS_CFLAGS) $(PCRE_CFLAGS) \
+  $(LIBVIRT_CFLAGS) $(LIBXML2_CFLAGS) \
   $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
 libguestfs_la_CPPFLAGS = -I$(top_srcdir)/gnulib/lib
@@ -161,7 +168,7 @@ guestfs_protocol.h: guestfs_protocol.x
 endif
 
 # Manual page.
-# guestfs-actions.pod, guestfs-availability.pod and guestfs-structs
+# guestfs-actions.pod, guestfs-availability.pod and guestfs-structs.pod
 # are autogenerated.  There is no include mechanism for POD, so we
 # have to do it by hand.