build: Centralize all POD manipulation in 'podwrapper.sh' script.
[libguestfs.git] / src / Makefile.am
index 8781274..4827e27 100644 (file)
 
 include $(top_srcdir)/subdir-rules.mk
 
+CLEANFILES = stamp-guestfs.pod
+
 generator_built = \
        guestfs_protocol.x \
-       guestfs.h
+       guestfs.h \
        guestfs-internal-actions.h \
        actions.c \
        bindtests.c \
@@ -165,30 +167,25 @@ guestfs_protocol.h: guestfs_protocol.x
 endif
 
 # Manual page.
-# guestfs-actions.pod, guestfs-availability.pod and guestfs-structs.pod
-# are autogenerated.  There is no include mechanism for POD, so we
-# have to do it by hand.
 
 man_MANS = guestfs.3 libguestfs.3
+noinst_DATA = $(top_builddir)/html/guestfs.3.html
+
+guestfs.3 $(top_builddir)/html/guestfs.3.html: stamp-guestfs.pod
 
-guestfs.3: guestfs.pod \
+stamp-guestfs.pod: guestfs.pod \
                guestfs-actions.pod \
                guestfs-availability.pod \
                guestfs-structs.pod
-       sed \
-         -e '/@ACTIONS@/rguestfs-actions.pod' \
-         -e 's/@ACTIONS@//' \
-         -e '/@AVAILABILITY@/rguestfs-availability.pod' \
-         -e 's/@AVAILABILITY@//' \
-         -e '/@STRUCTS@/rguestfs-structs.pod' \
-         -e 's/@STRUCTS@//' \
-         < $< | \
-       $(POD2MAN) \
+       $(top_srcdir)/podwrapper.sh \
          --section 3 \
-         -c "Virtualization Support" \
-         --name "guestfs" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         > $@
+         --man guestfs.3 \
+         --html $(top_builddir)/html/guestfs.3.html \
+         --insert guestfs-actions.pod:@ACTIONS@ \
+         --insert guestfs-availability.pod:@AVAILABILITY@ \
+         --insert guestfs-structs.pod:@STRUCTS@ \
+         $<
+       touch $@
 
 # Check user doesn't try to do 'make all' or 'make check' as root.
 # https://www.redhat.com/archives/libguestfs/2010-April/msg00098.html