fish: Add 'pulse mode' to the progress bar.
[libguestfs.git] / src / Makefile.am
index 4827e27..3e1201d 100644 (file)
@@ -127,6 +127,7 @@ libguestfs_la_SOURCES = \
        actions.c \
        appliance.c \
        bindtests.c \
+       events.c \
        filearch.c \
        inspect.c \
        launch.c \
@@ -186,14 +187,3 @@ stamp-guestfs.pod: guestfs.pod \
          --insert guestfs-structs.pod:@STRUCTS@ \
          $<
        touch $@
-
-# Check user doesn't try to do 'make all' or 'make check' as root.
-# https://www.redhat.com/archives/libguestfs/2010-April/msg00098.html
-
-all-local: checkroot
-check-local: checkroot
-checkroot:
-       @if [ "`id -u`" = 0 ]; then \
-           echo "*** Error: Don't run 'make' or 'make check' as root."; \
-           exit 1; \
-       fi