Fix rpcgen post-processing for out-of-tree builds
[libguestfs.git] / src / Makefile.am
index 4827e27..28a1b92 100644 (file)
@@ -13,7 +13,7 @@
 #
 # You should have received a copy of the GNU General Public License
 # along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
 
 include $(top_srcdir)/subdir-rules.mk
 
@@ -52,13 +52,10 @@ include_HEADERS = guestfs.h
 
 lib_LTLIBRARIES = libguestfs.la
 
-# This convenience library is solely to avoid compiler warnings
-# in its generated sources.
-libprotocol_la_SOURCES = \
-  guestfs_protocol.c \
-  guestfs_protocol.h
-
-libprotocol_la_CFLAGS =
+# This convenience library is solely to compile its generated sources with
+# custom flags.
+libprotocol_la_SOURCES = guestfs_protocol.c  guestfs_protocol.h
+libprotocol_la_CFLAGS = -Wall -Wno-unused -fno-strict-aliasing
 
 # Build the errnostring perfect hash code.  The generated code has lots
 # of warnings so we must compile it in a separate mini-library.
@@ -116,7 +113,7 @@ errnostring_gperf.c: errnostring_gperf.gperf
 # 'libguestfs.so.0.$(MAX_PROC_NR).0'.
 libguestfs_la_LDFLAGS = -version-info $(MAX_PROC_NR):0:$(MAX_PROC_NR)
 
-libguestfs_la_LDFLAGS += $(VERSION_SCRIPT_FLAGS)libguestfs.syms
+libguestfs_la_LDFLAGS += $(VERSION_SCRIPT_FLAGS)$(srcdir)/libguestfs.syms
 
 libguestfs_la_SOURCES = \
        guestfs.c \
@@ -127,10 +124,19 @@ libguestfs_la_SOURCES = \
        actions.c \
        appliance.c \
        bindtests.c \
+       dbdump.c \
+       events.c \
        filearch.c \
        inspect.c \
+       inspect_apps.c \
+       inspect_fs.c \
+       inspect_fs_cd.c \
+       inspect_fs_unix.c \
+       inspect_fs_windows.c \
+       inspect_icon.c \
        launch.c \
        listfs.c \
+       match.c \
        proto.c \
        virt.c \
        libguestfs.syms
@@ -138,7 +144,15 @@ libguestfs_la_SOURCES = \
 libguestfs_la_LIBADD = \
        $(HIVEX_LIBS) $(AUGEAS_LIBS) $(PCRE_LIBS) $(MAGIC_LIBS) \
        $(LIBVIRT_LIBS) $(LIBXML2_LIBS) \
-       $(LTLIBTHREAD) ../gnulib/lib/libgnu.la
+       ../gnulib/lib/libgnu.la \
+       $(GETADDRINFO_LIB) \
+       $(HOSTENT_LIB) \
+       $(INET_NTOP_LIB) \
+       $(LIBSOCKET) \
+       $(LIB_CLOCK_GETTIME) \
+       $(LIBINTL) \
+       $(LTLIBTHREAD) \
+       $(SERVENT_LIB)
 
 # Make libguestfs include the convenience libraries.
 noinst_LTLIBRARIES = liberrnostring.la libprotocol.la
@@ -146,23 +160,24 @@ libguestfs_la_LIBADD += liberrnostring.la libprotocol.la
 
 libguestfs_la_CFLAGS = \
   -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
+  -DGUESTFS_WARN_DEPRECATED=1 \
   $(HIVEX_CFLAGS) $(AUGEAS_CFLAGS) $(PCRE_CFLAGS) \
   $(LIBVIRT_CFLAGS) $(LIBXML2_CFLAGS) \
   $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
-libguestfs_la_CPPFLAGS = -I$(top_srcdir)/gnulib/lib
+libguestfs_la_CPPFLAGS = -I$(top_srcdir)/gnulib/lib -I$(top_builddir)/gnulib/lib
 
 if HAVE_RPCGEN
 guestfs_protocol.c: guestfs_protocol.x
        rm -f $@-t $@-t2
-       $(RPCGEN) -c -o $@-t $<
-       sed 's,\.\./\.\./src/,,' < $@-t > $@-t2
+       $(RPCGEN) -c -o $@-t $(srcdir)/$<
+       sed 's,\.\./\(\.\./\)*src,.,' < $@-t > $@-t2
        rm $@-t
        mv $@-t2 $@
 
 guestfs_protocol.h: guestfs_protocol.x
        rm -f $@-t
-       $(RPCGEN) -h -o $@-t $<
+       $(RPCGEN) -h -o $@-t $(srcdir)/$<
        mv $@-t $@
 endif
 
@@ -177,23 +192,12 @@ stamp-guestfs.pod: guestfs.pod \
                guestfs-actions.pod \
                guestfs-availability.pod \
                guestfs-structs.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --section 3 \
          --man guestfs.3 \
          --html $(top_builddir)/html/guestfs.3.html \
-         --insert guestfs-actions.pod:@ACTIONS@ \
-         --insert guestfs-availability.pod:@AVAILABILITY@ \
-         --insert guestfs-structs.pod:@STRUCTS@ \
+         --insert $(srcdir)/guestfs-actions.pod:@ACTIONS@ \
+         --insert $(srcdir)/guestfs-availability.pod:@AVAILABILITY@ \
+         --insert $(srcdir)/guestfs-structs.pod:@STRUCTS@ \
          $<
        touch $@
-
-# Check user doesn't try to do 'make all' or 'make check' as root.
-# https://www.redhat.com/archives/libguestfs/2010-April/msg00098.html
-
-all-local: checkroot
-check-local: checkroot
-checkroot:
-       @if [ "`id -u`" = 0 ]; then \
-           echo "*** Error: Don't run 'make' or 'make check' as root."; \
-           exit 1; \
-       fi