build: Set TMPDIR for local testing.
[libguestfs.git] / resize / Makefile.am
index 8ef16ff..fd7f71a 100644 (file)
@@ -19,7 +19,6 @@ include $(top_srcdir)/subdir-rules.mk
 
 EXTRA_DIST = \
        $(SOURCES) \
-       run-resize-locally \
        virt-resize.pod \
        test-virt-resize.sh
 
@@ -42,12 +41,16 @@ OBJECTS = \
 
 bin_SCRIPTS = virt-resize
 
-OCAMLPACKAGES = -package guestfs,pcre
+# -I $(top_builddir)/src/.libs is a hack which forces corresponding -L
+# option to be passed to gcc, so we don't try linking against an
+# installed copy of libguestfs.
+OCAMLPACKAGES = -package pcre -I $(top_builddir)/src/.libs -I ../ocaml
+
 OCAMLCFLAGS = -g -warn-error CDEFLMPSUVYZX $(OCAMLPACKAGES)
 OCAMLOPTFLAGS = $(OCAMLCFLAGS)
 
 virt-resize: $(OBJECTS)
-       $(OCAMLFIND) ocamlopt $(OCAMLOPTFLAGS) -linkpkg $^ -o $@
+       $(OCAMLFIND) ocamlopt $(OCAMLOPTFLAGS) mlguestfs.cmxa -linkpkg $^ -o $@
 
 .mli.cmi:
        $(OCAMLFIND) ocamlc $(OCAMLCFLAGS) -c $< -o $@
@@ -62,15 +65,16 @@ man_MANS = virt-resize.1
 
 noinst_DATA = $(top_builddir)/html/virt-resize.1.html
 
-virt-%.1: virt-%.pod
-       $(top_srcdir)/podwrapper.sh \
-         --man $@ \
-         $<
+virt-resize.1 $(top_builddir)/html/virt-resize.1.html: stamp-virt-resize.pod
 
-$(top_builddir)/html/virt-%.1.html: virt-%
+stamp-virt-resize.pod: virt-resize.pod
        $(top_srcdir)/podwrapper.sh \
-         --html $@ \
+         --man virt-resize.1 \
+         --html $(top_builddir)/html/virt-resize.1.html \
          $<
+       touch $@
+
+CLEANFILES += stamp-virt-resize.pod
 
 # Tests.
 
@@ -79,7 +83,8 @@ random_val := $(shell awk 'BEGIN{srand(); print 1+int(255*rand())}' < /dev/null)
 TESTS_ENVIRONMENT = \
        MALLOC_PERTURB_=$(random_val) \
        LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
-       LIBGUESTFS_PATH=$(top_builddir)/appliance
+       LIBGUESTFS_PATH=$(top_builddir)/appliance \
+       TMPDIR=$(top_builddir)
 
 TESTS = test-virt-resize.sh
 
@@ -99,3 +104,7 @@ include .depend
 
 endif
 endif
+
+# Parallel builds don't obey dependencies for some reason we
+# don't understand.
+.NOTPARALLEL: