Escape special/non-printing characters in debug output (RHBZ#731744).
[libguestfs.git] / resize / Makefile.am
index 3740a4a..93a2600 100644 (file)
@@ -19,7 +19,6 @@ include $(top_srcdir)/subdir-rules.mk
 
 EXTRA_DIST = \
        $(SOURCES) \
-       run-resize-locally \
        virt-resize.pod \
        test-virt-resize.sh
 
@@ -42,7 +41,11 @@ OBJECTS = \
 
 bin_SCRIPTS = virt-resize
 
-OCAMLPACKAGES = -package pcre -I ../ocaml
+# -I $(top_builddir)/src/.libs is a hack which forces corresponding -L
+# option to be passed to gcc, so we don't try linking against an
+# installed copy of libguestfs.
+OCAMLPACKAGES = -package pcre -I $(top_builddir)/src/.libs -I ../ocaml
+
 OCAMLCFLAGS = -g -warn-error CDEFLMPSUVYZX $(OCAMLPACKAGES)
 OCAMLOPTFLAGS = $(OCAMLCFLAGS)
 
@@ -65,12 +68,14 @@ noinst_DATA = $(top_builddir)/html/virt-resize.1.html
 virt-resize.1 $(top_builddir)/html/virt-resize.1.html: stamp-virt-resize.pod
 
 stamp-virt-resize.pod: virt-resize.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man virt-resize.1 \
          --html $(top_builddir)/html/virt-resize.1.html \
          $<
        touch $@
 
+CLEANFILES += stamp-virt-resize.pod
+
 # Tests.
 
 random_val := $(shell awk 'BEGIN{srand(); print 1+int(255*rand())}' < /dev/null)
@@ -78,7 +83,8 @@ random_val := $(shell awk 'BEGIN{srand(); print 1+int(255*rand())}' < /dev/null)
 TESTS_ENVIRONMENT = \
        MALLOC_PERTURB_=$(random_val) \
        LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
-       LIBGUESTFS_PATH=$(top_builddir)/appliance
+       LIBGUESTFS_PATH=$(top_builddir)/appliance \
+       TMPDIR=$(top_builddir)
 
 TESTS = test-virt-resize.sh
 
@@ -98,3 +104,7 @@ include .depend
 
 endif
 endif
+
+# Parallel builds don't obey dependencies for some reason we
+# don't understand.
+.NOTPARALLEL: