docs: Separate out combined =item 's in man pages.
[libguestfs.git] / resize / Makefile.am
index 93c193e..8418cb4 100644 (file)
@@ -19,7 +19,6 @@ include $(top_srcdir)/subdir-rules.mk
 
 EXTRA_DIST = \
        $(SOURCES) \
-       run-resize-locally \
        virt-resize.pod \
        test-virt-resize.sh
 
@@ -42,7 +41,11 @@ OBJECTS = \
 
 bin_SCRIPTS = virt-resize
 
-OCAMLPACKAGES = -package pcre -I ../ocaml
+# -I $(top_builddir)/src/.libs is a hack which forces corresponding -L
+# option to be passed to gcc, so we don't try linking against an
+# installed copy of libguestfs.
+OCAMLPACKAGES = -package pcre -I $(top_builddir)/src/.libs -I ../ocaml
+
 OCAMLCFLAGS = -g -warn-error CDEFLMPSUVYZX $(OCAMLPACKAGES)
 OCAMLOPTFLAGS = $(OCAMLCFLAGS)
 
@@ -71,6 +74,8 @@ stamp-virt-resize.pod: virt-resize.pod
          $<
        touch $@
 
+CLEANFILES += stamp-virt-resize.pod
+
 # Tests.
 
 random_val := $(shell awk 'BEGIN{srand(); print 1+int(255*rand())}' < /dev/null)