Revert "blkid: Use -c /dev/null because RHEL 5 blkid doesn't have -p option."
[libguestfs.git] / resize / Makefile.am
index 32c5325..5046a8c 100644 (file)
@@ -13,7 +13,7 @@
 #
 # You should have received a copy of the GNU General Public License
 # along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
 
 include $(top_srcdir)/subdir-rules.mk
 
@@ -25,7 +25,6 @@ EXTRA_DIST = \
 CLEANFILES = *~ *.cmi *.cmo *.cmx *.cmxa *.o virt-resize test.img
 
 if HAVE_OCAML
-if HAVE_OCAML_PCRE
 
 # Alphabetical order.
 SOURCES = \
@@ -49,7 +48,7 @@ bin_SCRIPTS = virt-resize
 # -I $(top_builddir)/src/.libs is a hack which forces corresponding -L
 # option to be passed to gcc, so we don't try linking against an
 # installed copy of libguestfs.
-OCAMLPACKAGES = -package pcre -I $(top_builddir)/src/.libs -I ../ocaml
+OCAMLPACKAGES = -package str -I $(top_builddir)/src/.libs -I ../ocaml
 
 OCAMLCFLAGS = -g -warn-error CDEFLMPSUVYZX $(OCAMLPACKAGES)
 OCAMLOPTFLAGS = $(OCAMLCFLAGS)
@@ -124,7 +123,6 @@ include .depend
 .PHONY: depend docs
 
 endif
-endif
 
 # Parallel builds don't obey dependencies for some reason we
 # don't understand.