daemon: debug segv correct use of dereferencing NULL.
[libguestfs.git] / rescue / Makefile.am
index 1208be1..cf173ce 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs virt-rescue
-# Copyright (C) 2010 Red Hat Inc.
+# Copyright (C) 2010-2011 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
 #
 # You should have received a copy of the GNU General Public License
 # along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
 
 include $(top_srcdir)/subdir-rules.mk
 
 EXTRA_DIST = \
-       run-rescue-locally \
        virt-rescue.pod
 
 CLEANFILES = stamp-virt-rescue.pod
@@ -26,6 +25,7 @@ CLEANFILES = stamp-virt-rescue.pod
 bin_PROGRAMS = virt-rescue
 
 SHARED_SOURCE_FILES = \
+       ../fish/config.c \
        ../fish/inspect.c \
        ../fish/keys.c \
        ../fish/options.h \
@@ -37,13 +37,16 @@ virt_rescue_SOURCES = \
        virt-rescue.c
 
 virt_rescue_CFLAGS = \
+       -DGUESTFS_WARN_DEPRECATED=1 \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        -I$(top_srcdir)/fish \
        -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
        -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
+       $(LIBCONFIG_CFLAGS) \
        $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
 virt_rescue_LDADD = \
+       $(LIBCONFIG_LIBS) \
        $(top_builddir)/src/libguestfs.la \
        ../gnulib/lib/libgnu.la
 
@@ -54,14 +57,8 @@ noinst_DATA = $(top_builddir)/html/virt-rescue.1.html
 virt-rescue.1 $(top_builddir)/html/virt-rescue.1.html: stamp-virt-rescue.pod
 
 stamp-virt-rescue.pod: virt-rescue.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man virt-rescue.1 \
          --html $(top_builddir)/html/virt-rescue.1.html \
          $<
        touch $@
-
-# Build a partly-static binary (for the binary distribution).
-
-virt-rescue.static$(EXEEXT): $(virt_rescue_OBJECTS) $(virt_rescue_DEPENDENCIES)
-       $(top_srcdir)/relink-static.sh \
-       $(virt_rescue_LINK) $(virt_rescue_OBJECTS) -static $(virt_rescue_LDADD) $(virt_rescue_LIBS) $(LIBVIRT_LIBS) $(LIBXML2_LIBS) -lpcre -lhivex -lmagic -lz -lm