Remove ad-hoc run*locally scripts, replace with './run'
[libguestfs.git] / rescue / Makefile.am
index a9a533c..0032a23 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs virt-rescue
-# Copyright (C) 2009 Red Hat Inc.
+# Copyright (C) 2010-2011 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
-EXTRA_DIST = \
-       run-rescue-locally \
-       virt-rescue.pl
-
-if HAVE_RESCUE
+include $(top_srcdir)/subdir-rules.mk
 
+EXTRA_DIST = \
+       virt-rescue.pod
+
+CLEANFILES = stamp-virt-rescue.pod
+
+bin_PROGRAMS = virt-rescue
+
+SHARED_SOURCE_FILES = \
+       ../fish/config.c \
+       ../fish/inspect.c \
+       ../fish/keys.c \
+       ../fish/options.h \
+       ../fish/options.c \
+       ../fish/virt.c
+
+virt_rescue_SOURCES = \
+       $(SHARED_SOURCE_FILES) \
+       virt-rescue.c
+
+virt_rescue_CFLAGS = \
+       -I$(top_srcdir)/src -I$(top_builddir)/src \
+       -I$(top_srcdir)/fish \
+       -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
+       -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
+       $(LIBCONFIG_CFLAGS) \
+       $(WARN_CFLAGS) $(WERROR_CFLAGS)
+
+virt_rescue_LDADD = \
+       $(LIBCONFIG_LIBS) \
+       $(top_builddir)/src/libguestfs.la \
+       ../gnulib/lib/libgnu.la
+
+# Manual pages and HTML files for the website.
 man_MANS = virt-rescue.1
+noinst_DATA = $(top_builddir)/html/virt-rescue.1.html
+
+virt-rescue.1 $(top_builddir)/html/virt-rescue.1.html: stamp-virt-rescue.pod
 
-noinst_DATA = @top_builddir@/html/virt-rescue.1.html
-
-virt-rescue.1: virt-rescue.pl
-       $(POD2MAN) \
-         --section 1 \
-         -c "Virtualization Support" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         $< > $@
-
-@top_builddir@/html/virt-rescue.1.html: virt-rescue.pl
-       mkdir -p @top_builddir@/html
-       cd @top_builddir@ && pod2html \
-         --css 'pod.css' \
-         --title 'virt-rescue, run a rescue shell on a virtual machine' \
-         --htmldir html \
-         --outfile html/virt-rescue.1.html \
-         rescue/$<
-
-install-data-hook:
-       mkdir -p $(DESTDIR)$(bindir)
-       install -m 0755 virt-rescue.pl $(DESTDIR)$(bindir)/virt-rescue
-
-endif
+stamp-virt-rescue.pod: virt-rescue.pod
+       $(top_srcdir)/podwrapper.sh \
+         --man virt-rescue.1 \
+         --html $(top_builddir)/html/virt-rescue.1.html \
+         $<
+       touch $@