python: Fixes for Python 3 (RHBZ#750889).
[libguestfs.git] / python / Makefile.am
index 76b92fd..2f543e7 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs Python bindings
-# Copyright (C) 2009 Red Hat Inc.
+# Copyright (C) 2009-2011 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -43,10 +43,13 @@ libguestfsmod_la_SOURCES = guestfs-py.c guestfs-py.h guestfs-py-byhand.c
 libguestfsmod_la_CFLAGS = -Wall -I$(PYTHON_INCLUDEDIR) \
                          -I$(top_srcdir)/src -I$(top_builddir)/src
 libguestfsmod_la_LIBADD = $(top_builddir)/src/libguestfs.la
+libguestfsmod_la_LDFLAGS = -avoid-version -shared
 
 TESTS_ENVIRONMENT = \
        LIBGUESTFS_PATH=$(top_builddir)/appliance \
-       PYTHONPATH=$(builddir):$(builddir)/.libs
+       PYTHONPATH=$(builddir):$(builddir)/.libs \
+       TMPDIR=$(top_builddir) \
+       PYTHON=$(PYTHON)
 
 TESTS = run-bindtests run-python-tests