build: Centralize all POD manipulation in 'podwrapper.sh' script.
[libguestfs.git] / po-docs / ja / Makefile.am
index f565410..24eb24e 100644 (file)
@@ -36,63 +36,49 @@ MANPAGES = \
 EXTRA_DIST = \
        $(MANPAGES) \
        guestfs.pod guestfs-actions.pod guestfs-availability.pod guestfs-structs.pod \
-       guestfish.pod guestfish-actions.pod \
+       guestfish.pod guestfish-actions.pod guestfish-commands.pod \
        guestmount.pod \
        libguestfs-test-tool.pod \
        $(wildcard virt-*.pl)
 
-all-local: $(MANPAGES)
-
 if HAVE_PO4A
 
+all-local: $(MANPAGES)
+
 guestfs.3: guestfs.pod guestfs-actions.pod guestfs-availability.pod guestfs-structs.pod
-       sed \
-         -e '/@ACTIONS@/rguestfs-actions.pod' \
-         -e 's/@ACTIONS@//' \
-         -e '/@AVAILABILITY@/rguestfs-availability.pod' \
-         -e 's/@AVAILABILITY@//' \
-         -e '/@STRUCTS@/rguestfs-structs.pod' \
-         -e 's/@STRUCTS@//' \
-       < $< | \
-       $(POD2MAN) -u \
+       $(top_srcdir)/podwrapper.sh \
          --section 3 \
-         -c "Virtualization Support" \
-         --name "guestfs" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         > $@-t; mv $@-t $@
-
-guestfish.1: guestfish.pod guestfish-actions.pod
-       sed \
-         -e '/@ACTIONS@/rguestfish-actions.pod' -e 's/@ACTIONS@//' \
-         < $< | \
-       $(POD2MAN) -u \
-         --section 1 \
-         -c "Virtualization Support" \
-         --name "guestfish" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         > $@-t; mv $@-t $@
+         --man $@ \
+         --insert guestfs-actions.pod:@ACTIONS@ \
+         --insert guestfs-availability.pod:@AVAILABILITY@ \
+         --insert guestfs-structs.pod:@STRUCTS@ \
+         $<
+
+guestfish.1: guestfish.pod guestfish-actions.pod guestfish-commands.pod
+       $(top_srcdir)/podwrapper.sh \
+         --man $@ \
+         --insert guestfish-actions.pod:@ACTIONS@ \
+         --insert guestfish-commands.pod:@FISH_COMMANDS@ \
+         $<
 
 guestmount.1: guestmount.pod
-       $(POD2MAN) -u \
-         --section 1 \
-         -c "Virtualization Support" \
-         --name "guestmount" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         $< > $@-t; mv $@-t $@
+       $(top_srcdir)/podwrapper.sh \
+         --man $@ \
+         $<
 
 libguestfs-test-tool.1: libguestfs-test-tool.pod
-       $(POD2MAN) -u \
-         --section 1 \
-         -c "Virtualization Support" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         $< > $@-t; mv $@-t $@
+       $(top_srcdir)/podwrapper.sh \
+         --man $@ \
+         $<
 
 virt-%.1: virt-%.pl
-       $(POD2MAN) -u \
-         --section 1 \
-         -c "Virtualization Support" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         $< > $@-t && mv $@-t $@
+       $(top_srcdir)/podwrapper.sh \
+         --man $@ \
+         $<
+
+else
+
+all-local:
 
 endif