build: Centralize all POD manipulation in 'podwrapper.sh' script.
[libguestfs.git] / po-docs / ja / Makefile.am
index e088ebb..24eb24e 100644 (file)
@@ -23,7 +23,6 @@ LINGUA = $(shell basename -- `pwd`)
 
 CLEANFILES = *.1 *.3
 
-# Ship the final translated manpages in the tarball.
 MANPAGES = \
        guestfs.3 \
        guestfish.1 \
@@ -31,58 +30,57 @@ MANPAGES = \
        guestmount.1 \
        $(patsubst %.pl,%.1,$(wildcard virt-*.pl))
 
-EXTRA_DIST = $(MANPAGES)
+# Ship the POD files and the translated manpages in the tarball.  This
+# just simplifies building from the tarball, at a small cost in extra
+# size.
+EXTRA_DIST = \
+       $(MANPAGES) \
+       guestfs.pod guestfs-actions.pod guestfs-availability.pod guestfs-structs.pod \
+       guestfish.pod guestfish-actions.pod guestfish-commands.pod \
+       guestmount.pod \
+       libguestfs-test-tool.pod \
+       $(wildcard virt-*.pl)
+
+if HAVE_PO4A
 
 all-local: $(MANPAGES)
 
 guestfs.3: guestfs.pod guestfs-actions.pod guestfs-availability.pod guestfs-structs.pod
-       sed \
-         -e '/@ACTIONS@/rguestfs-actions.pod' \
-         -e 's/@ACTIONS@//' \
-         -e '/@AVAILABILITY@/rguestfs-availability.pod' \
-         -e 's/@AVAILABILITY@//' \
-         -e '/@STRUCTS@/rguestfs-structs.pod' \
-         -e 's/@STRUCTS@//' \
-       < $< | \
-       $(POD2MAN) -u \
+       $(top_srcdir)/podwrapper.sh \
          --section 3 \
-         -c "Virtualization Support" \
-         --name "guestfs" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         > $@-t; mv $@-t $@
-
-guestfish.1: guestfish.pod guestfish-actions.pod
-       sed \
-         -e '/@ACTIONS@/rguestfish-actions.pod' -e 's/@ACTIONS@//' \
-         < $< | \
-       $(POD2MAN) -u \
-         --section 1 \
-         -c "Virtualization Support" \
-         --name "guestfish" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         > $@-t; mv $@-t $@
+         --man $@ \
+         --insert guestfs-actions.pod:@ACTIONS@ \
+         --insert guestfs-availability.pod:@AVAILABILITY@ \
+         --insert guestfs-structs.pod:@STRUCTS@ \
+         $<
+
+guestfish.1: guestfish.pod guestfish-actions.pod guestfish-commands.pod
+       $(top_srcdir)/podwrapper.sh \
+         --man $@ \
+         --insert guestfish-actions.pod:@ACTIONS@ \
+         --insert guestfish-commands.pod:@FISH_COMMANDS@ \
+         $<
 
 guestmount.1: guestmount.pod
-       $(POD2MAN) -u \
-         --section 1 \
-         -c "Virtualization Support" \
-         --name "guestmount" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         $< > $@-t; mv $@-t $@
+       $(top_srcdir)/podwrapper.sh \
+         --man $@ \
+         $<
 
 libguestfs-test-tool.1: libguestfs-test-tool.pod
-       $(POD2MAN) -u \
-         --section 1 \
-         -c "Virtualization Support" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         $< > $@-t; mv $@-t $@
+       $(top_srcdir)/podwrapper.sh \
+         --man $@ \
+         $<
 
 virt-%.1: virt-%.pl
-       $(POD2MAN) -u \
-         --section 1 \
-         -c "Virtualization Support" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         $< > $@-t && mv $@-t $@
+       $(top_srcdir)/podwrapper.sh \
+         --man $@ \
+         $<
+
+else
+
+all-local:
+
+endif
 
 # XXX Can automake do this properly?
 install-data-hook: