daemon: debug segv correct use of dereferencing NULL.
[libguestfs.git] / po-docs / Makefile.am
index ede07e7..f9af41b 100644 (file)
@@ -13,7 +13,7 @@
 #
 # You should have received a copy of the GNU General Public License
 # along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
 
 # XXX The use of po4a is naive here.  Also we should integrate this
 # into the po/ directory and the translations into the usual
@@ -50,7 +50,8 @@ libguestfs-docs.pot: po4a.conf
          --copyright-holder "Red Hat Inc." \
          po4a.conf
        for f in `find $(LINGUAS) -name '*.pod' -o -name '*.pl'`; do \
-         awk 'FNR >= 14 { print }' < $$f > $$f.new; \
+         echo '=encoding utf8' > $$f.new; \
+         awk 'FNR >= 14 { print }' < $$f >> $$f.new; \
          mv $$f.new $$f; \
        done
 
@@ -68,8 +69,11 @@ po4a.conf: podfiles
 podfiles: Makefile
        rm -f $@ $@-t
        find $(top_srcdir) -name '*.pod' | \
-         grep -v /stamp- | \
-         grep -v /po-docs/ > $@-t
+         grep -v /debian/ | \
+         grep -v /libguestfs-1 | \
+         grep -v /po-docs/ | \
+         grep -v /stamp- \
+         > $@-t
        find $(top_srcdir)/tools -name 'virt-*.pl' >> $@-t
-       sort -o $@-t $@-t
+       LC_ALL=C sort -o $@-t $@-t
        mv $@-t $@