perl: Rerun configure if MAX_PROC_NR changes.
[libguestfs.git] / perl / Makefile.am
index b766244..e1a6455 100644 (file)
@@ -39,18 +39,30 @@ if HAVE_PERL
 # Interfacing automake and ExtUtils::MakeMaker known to be
 # a nightmare, news at 11.
 
 # Interfacing automake and ExtUtils::MakeMaker known to be
 # a nightmare, news at 11.
 
+# src/ dependencies
+.PHONY: src_deps
+src_deps: $(top_builddir)/src/libguestfs.la $(generator_built)
+
+# Images used by tests
+.PHONY: test_images
+test_images:
+       $(MAKE) -C $(top_builddir)/images
+
 TESTS = run-bindtests run-perl-tests
 
 TESTS = run-bindtests run-perl-tests
 
+$(TESTS): src_deps all appliance test_images
+
 TESTS_ENVIRONMENT = \
        LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
        LIBGUESTFS_PATH=$(top_builddir)/appliance
 
 INSTALLDIRS = site
 
 TESTS_ENVIRONMENT = \
        LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
        LIBGUESTFS_PATH=$(top_builddir)/appliance
 
 INSTALLDIRS = site
 
-all: Makefile-pl $(generator_built)
+all: Makefile-pl src_deps
        $(MAKE) -f Makefile-pl
 
        $(MAKE) -f Makefile-pl
 
-Makefile-pl: Makefile.PL
+Makefile-pl: Makefile.PL $(top_srcdir)/src/MAX_PROC_NR
+       cd $(top_srcdir) && ./config.status --recheck
        perl Makefile.PL INSTALLDIRS=$(INSTALLDIRS) PREFIX=$(prefix)
 
 # No!  Otherwise it is deleted before the clean-local rule runs.
        perl Makefile.PL INSTALLDIRS=$(INSTALLDIRS) PREFIX=$(prefix)
 
 # No!  Otherwise it is deleted before the clean-local rule runs.