build: Ensure building appliance depends on guestfsd
[libguestfs.git] / perl / Makefile.am
index 9e32969..b766244 100644 (file)
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
+include $(top_srcdir)/subdir-rules.mk
+
+generator_built = \
+       Guestfs.xs \
+       lib/Sys/Guestfs.pm \
+       bindtests.pl
+
 EXTRA_DIST = \
+       $(generator_built) \
        Makefile.PL.in \
-       Guestfs.xs \
        examples/README \
        examples/LICENSE \
        examples/*.pl \
-       lib/Sys/Guestfs.pm \
        lib/Sys/Guestfs/Lib.pm \
        run-bindtests \
        run-perl-tests \
-       bindtests.pl \
        t/*.t \
        typemap
 
@@ -42,16 +47,18 @@ TESTS_ENVIRONMENT = \
 
 INSTALLDIRS = site
 
-all: Makefile-pl
+all: Makefile-pl $(generator_built)
        $(MAKE) -f Makefile-pl
 
 Makefile-pl: Makefile.PL
        perl Makefile.PL INSTALLDIRS=$(INSTALLDIRS) PREFIX=$(prefix)
 
-CLEANFILES = Makefile-pl
+# No!  Otherwise it is deleted before the clean-local rule runs.
+#CLEANFILES = Makefile-pl
 
 clean-local:
        -$(MAKE) -f Makefile-pl clean
+       rm -f Makefile-pl
 
 install-data-hook:
        $(MAKE) -f Makefile-pl DESTDIR=$(DESTDIR) install