remove superflous debirf scripts
[libguestfs.git] / perl / Makefile.am
index 52a6a09..747ac43 100644 (file)
@@ -22,7 +22,9 @@ EXTRA_DIST = \
        examples/LICENSE \
        examples/*.pl \
        lib/Sys/Guestfs.pm \
+       run-bindtests \
        run-perl-tests \
+       bindtests.pl \
        t/*.t \
        typemap
 
@@ -31,14 +33,20 @@ if HAVE_PERL
 # Interfacing automake and ExtUtils::MakeMaker known to be
 # a nightmare, news at 11.
 
-TESTS = run-perl-tests
+TESTS = run-bindtests run-perl-tests
+
+TESTS_ENVIRONMENT = \
+       LD_LIBRARY_PATH=../src/.libs \
+       LIBGUESTFS_PATH=../appliance
 
 INSTALLDIRS = site
 
-all:
-       perl Makefile.PL INSTALLDIRS=$(INSTALLDIRS) PREFIX=$(prefix)
+all: Makefile-pl
        $(MAKE) -f Makefile-pl
 
+Makefile-pl: Makefile.PL
+       perl Makefile.PL INSTALLDIRS=$(INSTALLDIRS) PREFIX=$(prefix)
+
 install-data-hook:
        $(MAKE) -f Makefile-pl DESTDIR=$(DESTDIR) install