build: Fix automake warnings
[libguestfs.git] / perl / Makefile.am
index 4b7ed99..5ee6c49 100644 (file)
 #
 # You should have received a copy of the GNU General Public License
 # along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
+include $(top_srcdir)/subdir-rules.mk
+
+generator_built = \
+       Guestfs.xs \
+       lib/Sys/Guestfs.pm \
+       bindtests.pl
 
 EXTRA_DIST = \
+       $(generator_built) \
        Makefile.PL.in \
-       Guestfs.xs \
        examples/README \
        examples/LICENSE \
        examples/*.pl \
-       lib/Sys/Guestfs.pm \
        lib/Sys/Guestfs/Lib.pm \
        run-bindtests \
        run-perl-tests \
-       bindtests.pl \
        t/*.t \
        typemap
 
@@ -34,15 +39,25 @@ if HAVE_PERL
 # Interfacing automake and ExtUtils::MakeMaker known to be
 # a nightmare, news at 11.
 
+# src/ dependencies
+src_deps: $(top_builddir)/src/libguestfs.la $(generator_built)
+
+# Images used by tests
+test_images:
+       $(MAKE) -C $(top_builddir)/tests/data
+
 TESTS = run-bindtests run-perl-tests
 
+$(TESTS): src_deps all appliance test_images
+
 TESTS_ENVIRONMENT = \
        LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
-       LIBGUESTFS_PATH=$(top_builddir)/appliance
+       LIBGUESTFS_PATH=$(top_builddir)/appliance \
+       TMPDIR=$(top_builddir)
 
 INSTALLDIRS = site
 
-all: Makefile-pl
+all: Makefile-pl src_deps
        $(MAKE) -f Makefile-pl
 
 Makefile-pl: Makefile.PL
@@ -59,3 +74,5 @@ install-data-hook:
        $(MAKE) -f Makefile-pl DESTDIR=$(DESTDIR) install
 
 endif
+
+.PHONY: src_deps test_images