Fix for non-srcdir builds: more misc fixes.
[libguestfs.git] / perl / Makefile.am
index 9e32969..4b7ed99 100644 (file)
@@ -48,10 +48,12 @@ all: Makefile-pl
 Makefile-pl: Makefile.PL
        perl Makefile.PL INSTALLDIRS=$(INSTALLDIRS) PREFIX=$(prefix)
 
-CLEANFILES = Makefile-pl
+# No!  Otherwise it is deleted before the clean-local rule runs.
+#CLEANFILES = Makefile-pl
 
 clean-local:
        -$(MAKE) -f Makefile-pl clean
+       rm -f Makefile-pl
 
 install-data-hook:
        $(MAKE) -f Makefile-pl DESTDIR=$(DESTDIR) install