Add libguestfs-test-tool.
[libguestfs.git] / perl / Makefile.am
index 747ac43..4b7ed99 100644 (file)
@@ -22,6 +22,7 @@ EXTRA_DIST = \
        examples/LICENSE \
        examples/*.pl \
        lib/Sys/Guestfs.pm \
+       lib/Sys/Guestfs/Lib.pm \
        run-bindtests \
        run-perl-tests \
        bindtests.pl \
@@ -36,8 +37,8 @@ if HAVE_PERL
 TESTS = run-bindtests run-perl-tests
 
 TESTS_ENVIRONMENT = \
-       LD_LIBRARY_PATH=../src/.libs \
-       LIBGUESTFS_PATH=../appliance
+       LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
+       LIBGUESTFS_PATH=$(top_builddir)/appliance
 
 INSTALLDIRS = site
 
@@ -47,6 +48,13 @@ all: Makefile-pl
 Makefile-pl: Makefile.PL
        perl Makefile.PL INSTALLDIRS=$(INSTALLDIRS) PREFIX=$(prefix)
 
+# No!  Otherwise it is deleted before the clean-local rule runs.
+#CLEANFILES = Makefile-pl
+
+clean-local:
+       -$(MAKE) -f Makefile-pl clean
+       rm -f Makefile-pl
+
 install-data-hook:
        $(MAKE) -f Makefile-pl DESTDIR=$(DESTDIR) install