Parse /etc/modprobe.conf and initrd to give us a closer understanding
[libguestfs.git] / perl / Makefile.am
index 52a6a09..44ac42c 100644 (file)
@@ -22,7 +22,9 @@ EXTRA_DIST = \
        examples/LICENSE \
        examples/*.pl \
        lib/Sys/Guestfs.pm \
+       run-bindtests \
        run-perl-tests \
+       bindtests.pl \
        t/*.t \
        typemap
 
@@ -31,7 +33,11 @@ if HAVE_PERL
 # Interfacing automake and ExtUtils::MakeMaker known to be
 # a nightmare, news at 11.
 
-TESTS = run-perl-tests
+TESTS = run-bindtests run-perl-tests
+
+TESTS_ENVIRONMENT = \
+       LD_LIBRARY_PATH=../src/.libs \
+       LIBGUESTFS_PATH=../appliance
 
 INSTALLDIRS = site