cat: Give a better error if the user specified no drives on command line.
[libguestfs.git] / ocaml / examples / Makefile.am
index b516647..c251409 100644 (file)
@@ -1,4 +1,6 @@
-EXTRA_DIST = LICENSE README lvs.ml viewer.ml Throbber.png Throbber.gif
+EXTRA_DIST = \
+       LICENSE README \
+       lvs.ml
 
 CLEANFILES = throbber.ml *.cmi *.cmo *.cmx *.o lvs
 
@@ -6,28 +8,10 @@ if HAVE_OCAML
 
 noinst_SCRIPTS = lvs
 
-lvs:   lvs.ml
-       $(OCAMLFIND) ocamlopt -warn-error A -I .. mlguestfs.cmxa $< -o $@
-
-if BUILD_OCAML_VIEWER
-
-noinst_SCRIPTS += viewer
+OCAMLFINDFLAGS = -cclib -L$(top_builddir)/src/.libs
 
-viewer: throbber.ml xmllight_loader.mli xmllight_loader.ml viewer.ml
-       ocamlducefind opt \
-         -warn-error A \
-         -thread \
-         -package libvirt,lablgtk2,extlib,xml-light,ocamlduce,threads -I .. \
-         -predicates init,threads \
-         -linkpkg mlguestfs.cmxa gtkThread.cmx \
-         $^ -o $@
-
-throbber.ml: Throbber.png Throbber.gif
-       gdk_pixbuf_mlsource --build-list \
-         static Throbber.png \
-         animation Throbber.gif \
-         > $@-t && mv $@-t $@
+lvs:   lvs.ml
+       $(OCAMLFIND) ocamlopt $(OCAMLFINDFLAGS) \
+          -warn-error A -I .. mlguestfs.cmxa $< -o $@
 
 endif
-
-endif
\ No newline at end of file