abs_top_builddir doesn't exist in old RHEL 5 automake, use top_builddir instead.
[libguestfs.git] / ocaml / Makefile.am
index fde3853..760caf6 100644 (file)
@@ -23,8 +23,8 @@ EXTRA_DIST = \
 
 SUBDIRS = examples
 
-CLEANFILES = *~ *.cmi *.cmo *.cmx *.cma *.cmxa *.o *.a *.so
-CLEANFILES += t/*~ t/*.cmi t/*.cmo t/*.cmx t/*.o t/*.a t/*.so
+CLEANFILES = *.cmi *.cmo *.cmx *.cma *.cmxa *.o *.a *.so
+CLEANFILES += t/*.cmi t/*.cmo t/*.cmx t/*.o t/*.a t/*.so
 
 if HAVE_OCAML
 
@@ -43,19 +43,20 @@ guestfs_c_actions.o: guestfs_c_actions.c
        $(CC) $(CFLAGS) -I$(OCAMLLIB) -I$(top_builddir)/src -fPIC -Wall -c $<
 
 TESTS_ENVIRONMENT = \
-       LD_LIBRARY_PATH=$(abs_top_builddir)/src/.libs \
-       LIBGUESTFS_PATH=$(abs_top_builddir)
+       LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
+       LIBGUESTFS_PATH=$(top_builddir) \
+       $(VG)
 
 TESTS = t/guestfs_005_load t/guestfs_010_launch t/guestfs_050_lvcreate
 noinst_DATA += $(TESTS)
 
-t/guestfs_005_load: t/guestfs_005_load.ml
+t/guestfs_005_load: t/guestfs_005_load.ml mlguestfs.cmxa
        $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . unix.cmxa mlguestfs.cmxa $< -o $@
 
-t/guestfs_010_launch: t/guestfs_010_launch.ml
+t/guestfs_010_launch: t/guestfs_010_launch.ml mlguestfs.cmxa
        $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . unix.cmxa mlguestfs.cmxa $< -o $@
 
-t/guestfs_050_lvcreate: t/guestfs_050_lvcreate.ml
+t/guestfs_050_lvcreate: t/guestfs_050_lvcreate.ml mlguestfs.cmxa
        $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . unix.cmxa mlguestfs.cmxa $< -o $@
 
 .mli.cmi:
@@ -86,4 +87,4 @@ install-data-hook:
 
 CLEANFILES += $(noinst_DATA)
 
-endif
\ No newline at end of file
+endif