Stable OCaml dependencies.
[libguestfs.git] / ocaml / Makefile.am
index 77c5be9..28c13c5 100644 (file)
@@ -25,8 +25,10 @@ generator_built = \
 
 EXTRA_DIST = \
        $(generator_built) \
+       .depend \
        guestfs_c.c guestfs_c.h \
-       .depend META.in \
+       html/.gitignore \
+       META.in \
        run-bindtests \
        t/*.ml
 
@@ -38,7 +40,6 @@ AM_CPPFLAGS = -I$(top_builddir) -I$(OCAMLLIB) -I$(top_srcdir)/ocaml \
   $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
 if HAVE_OCAML
-if HAVE_XML_LIGHT
 
 noinst_DATA = mlguestfs.cma mlguestfs.cmxa META
 
@@ -55,43 +56,49 @@ guestfs_c.o: guestfs_c.c
        $(CC) $(AM_CPPFLAGS) $(CFLAGS) -fPIC -Wall -c $<
 
 guestfs_c_actions.o: guestfs_c_actions.c
-       $(CC) $(AM_CPPFLAGS) $(CFLAGS) -fPIC -Wall -c $<
+       $(CC) $(AM_CPPFLAGS) $(CFLAGS) -fPIC -Wall -c $(srcdir)/$<
+
+if HAVE_OCAMLDOC
+
+noinst_DATA += html/index.html
+
+html/index.html: $(srcdir)/guestfs*.mli $(srcdir)/guestfs*.ml
+       mkdir -p html
+       -$(OCAMLDOC) -d html -html $^
+endif
 
 TESTS_ENVIRONMENT = \
        LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
        LIBGUESTFS_PATH=$(top_builddir)/appliance \
+       TMPDIR=$(top_builddir) \
        $(VG)
 
 TESTS = run-bindtests \
-       t/guestfs_005_load t/guestfs_010_launch t/guestfs_050_lvcreate \
-       t/guestfs_060_readdir t/guestfs_070_threads \
+       t/guestfs_005_load \
+       t/guestfs_010_basic \
+       t/guestfs_070_threads \
        t/guestfs_080_optargs \
+       t/guestfs_400_events \
        t/guestfs_400_progress
 noinst_DATA += bindtests \
-       t/guestfs_005_load t/guestfs_010_launch t/guestfs_050_lvcreate \
-       t/guestfs_060_readdir t/guestfs_070_threads \
+       t/guestfs_005_load \
+       t/guestfs_010_basic \
+       t/guestfs_070_threads \
        t/guestfs_080_optargs \
+       t/guestfs_400_events \
        t/guestfs_400_progress
 
 bindtests: bindtests.cmx mlguestfs.cmxa
        mkdir -p t
-       $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . -package xml-light,unix -linkpkg mlguestfs.cmxa $< -o $@
+       $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . -package unix -linkpkg mlguestfs.cmxa $< -o $@
 
 t/guestfs_005_load: t/guestfs_005_load.cmx mlguestfs.cmxa
        mkdir -p t
-       $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . -package xml-light,unix -linkpkg mlguestfs.cmxa $< -o $@
-
-t/guestfs_010_launch: t/guestfs_010_launch.cmx mlguestfs.cmxa
-       mkdir -p t
-       $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . -package xml-light,unix -linkpkg mlguestfs.cmxa $< -o $@
-
-t/guestfs_050_lvcreate: t/guestfs_050_lvcreate.cmx mlguestfs.cmxa
-       mkdir -p t
-       $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . -package xml-light,unix -linkpkg mlguestfs.cmxa $< -o $@
+       $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . -package unix -linkpkg mlguestfs.cmxa $< -o $@
 
-t/guestfs_060_readdir: t/guestfs_060_readdir.cmx mlguestfs.cmxa
+t/guestfs_010_basic: t/guestfs_010_basic.cmx mlguestfs.cmxa
        mkdir -p t
-       $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . -package xml-light,unix -linkpkg mlguestfs.cmxa $< -o $@
+       $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . -package unix -linkpkg mlguestfs.cmxa $< -o $@
 
 t/guestfs_070_threads: t/guestfs_070_threads.cmx mlguestfs.cmxa
        mkdir -p t
@@ -99,11 +106,15 @@ t/guestfs_070_threads: t/guestfs_070_threads.cmx mlguestfs.cmxa
 
 t/guestfs_080_optargs: t/guestfs_080_optargs.cmx mlguestfs.cmxa
        mkdir -p t
-       $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . -package xml-light,unix -linkpkg mlguestfs.cmxa $< -o $@
+       $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . -package unix -linkpkg mlguestfs.cmxa $< -o $@
+
+t/guestfs_400_events: t/guestfs_400_events.cmx mlguestfs.cmxa
+       mkdir -p t
+       $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . -package unix -linkpkg mlguestfs.cmxa $< -o $@
 
 t/guestfs_400_progress: t/guestfs_400_progress.cmx mlguestfs.cmxa
        mkdir -p t
-       $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . -package xml-light,unix -linkpkg mlguestfs.cmxa $< -o $@
+       $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . -package unix -linkpkg mlguestfs.cmxa $< -o $@
 
 # Need to rebuild the tests from source if the main library has
 # changed at all, otherwise we get inconsistent assumptions.
@@ -111,20 +122,23 @@ t/guestfs_070_threads.cmx: t/guestfs_070_threads.ml mlguestfs.cmxa
        $(OCAMLFIND) ocamlopt -package unix,threads -thread -linkpkg -c $< -o $@
 
 t/%.cmx: t/%.ml mlguestfs.cmxa
-       $(OCAMLFIND) ocamlopt -package xml-light,unix -linkpkg -c $< -o $@
+       $(OCAMLFIND) ocamlopt -package unix -linkpkg -c $< -o $(builddir)/$@
 
-.mli.cmi:
-       $(OCAMLFIND) ocamlc -package xml-light,unix -c $< -o $@
-.ml.cmo:
-       $(OCAMLFIND) ocamlc -package xml-light,unix -c $< -o $@
-.ml.cmx:
-       $(OCAMLFIND) ocamlopt -package xml-light,unix -c $< -o $@
+%.cmi: %.mli
+       $(OCAMLFIND) ocamlc -package unix -c $< -o $(builddir)/$@
+%.cmo: %.ml
+       $(OCAMLFIND) ocamlc -package unix -c $< -o $(builddir)/$@
+%.cmx: %.ml
+       $(OCAMLFIND) ocamlopt -package unix -c $< -o $(builddir)/$@
 
 depend: .depend
 
 .depend: $(wildcard *.mli) $(wildcard *.ml)
        rm -f $@ $@-t
-       $(OCAMLFIND) ocamldep $^ | sed 's/  *$$//' | sort > $@-t
+       $(OCAMLFIND) ocamldep $^ | \
+         $(SED) 's/ *$$//' | \
+         $(SED) -e :a -e '/ *\\$$/N; s/ *\\\n */ /; ta' | \
+         sort > $@-t
        mv $@-t $@
 
 include .depend
@@ -138,12 +152,11 @@ install-data-hook:
        $(OCAMLFIND) install \
          -ldconf ignore -destdir $(DESTDIR)$(OCAMLLIB) \
          guestfs \
-         META *.so *.a *.cma *.cmx *.cmxa *.cmi *.mli
+         META *.so *.a *.cma *.cmx *.cmxa *.cmi $(srcdir)/*.mli
 
 CLEANFILES += $(noinst_DATA)
 
 endif
-endif
 
 # Tell version 3.79 and up of GNU make to not build goals in this
 # directory in parallel.  (Possible solution for RHBZ#502309).