tests: Split images -> tests/data + tests/guests
[libguestfs.git] / inspector / Makefile.am
index 7e36611..8ef8734 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs virt-inspector
-# Copyright (C) 2009-2010 Red Hat Inc.
+# Copyright (C) 2009-2011 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -13,7 +13,7 @@
 #
 # You should have received a copy of the GNU General Public License
 # along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
 
 include $(top_srcdir)/subdir-rules.mk
 
@@ -21,10 +21,18 @@ EXAMPLE_XML = \
        example-debian.xml \
        example-fedora.xml \
        example-ubuntu.xml \
-       example-windows.xml
+       example-windows.xml \
+       example-debian-netinst-cd.xml \
+       example-fedora-dvd.xml \
+       example-fedora-netinst-cd.xml \
+       example-rhel-6-dvd.xml \
+       example-rhel-6-netinst-cd.xml \
+       example-ubuntu-live-cd.xml \
+       example-windows-2003-x64-cd.xml \
+       example-windows-2003-x86-cd.xml \
+       example-windows-xp-cd.xml
 
 EXTRA_DIST = \
-       run-inspector-locally \
        virt-inspector.pod
 
 CLEANFILES = stamp-virt-inspector.pod
@@ -39,6 +47,7 @@ if HAVE_LIBXML2
 bin_PROGRAMS = virt-inspector
 
 SHARED_SOURCE_FILES = \
+       ../fish/config.c \
        ../fish/inspect.c \
        ../fish/keys.c \
        ../fish/options.h \
@@ -50,14 +59,17 @@ virt_inspector_SOURCES = \
        virt-inspector.c
 
 virt_inspector_CFLAGS = \
+       -DGUESTFS_WARN_DEPRECATED=1 \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        -I$(top_srcdir)/fish \
        -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
        -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
        $(LIBXML2_CFLAGS) \
+       $(LIBCONFIG_CFLAGS) \
        $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
 virt_inspector_LDADD = \
+       $(LIBCONFIG_LIBS) \
        $(top_builddir)/src/libguestfs.la \
        $(LIBXML2_LIBS) \
        ../gnulib/lib/libgnu.la
@@ -69,7 +81,7 @@ noinst_DATA = $(top_builddir)/html/virt-inspector.1.html
 virt-inspector.1 $(top_builddir)/html/virt-inspector.1.html: stamp-virt-inspector.pod
 
 stamp-virt-inspector.pod: virt-inspector.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man virt-inspector.1 \
          --html $(top_builddir)/html/virt-inspector.1.html \
          $<
@@ -78,7 +90,7 @@ stamp-virt-inspector.pod: virt-inspector.pod
 if HAVE_XMLLINT
 
 TESTS = $(EXAMPLE_XML)
-TESTS_ENVIRONMENT = $(XMLLINT) --noout --relaxng virt-inspector.rng
+TESTS_ENVIRONMENT = $(XMLLINT) --noout --relaxng $(srcdir)/virt-inspector.rng
 
 endif
 
@@ -88,10 +100,19 @@ endif
 # can run them.  Instead you can run them by hand.
 
 example-debian.xml:
-       ./run-inspector-locally ../images/debian.img > $@
+       rm -f $@ $@-t
+       ../run $(builddir)/virt-inspector ../tests/guests/debian.img > $@-t
+       mv $@-t $@
 example-fedora.xml:
-       ./run-inspector-locally ../images/fedora.img > $@
+       rm -f $@ $@-t
+       ../run $(builddir)/virt-inspector ../tests/guests/fedora.img > $@-t
+       mv $@-t $@
 example-ubuntu.xml:
-       ./run-inspector-locally ../images/ubuntu.img > $@
+       rm -f $@ $@-t
+       ../run $(builddir)/virt-inspector ../tests/guests/ubuntu.img > $@-t
+       mv $@-t $@
 example-windows.xml:
-       ./run-inspector-locally ../images/windows.img | fgrep -v '<uuid>' > $@
+       rm -f $@ $@-t
+       ../run $(builddir)/virt-inspector ../tests/guests/windows.img | \
+           fgrep -v '<uuid>' > $@-t
+       mv $@-t $@