debian: Build libguestfs-ocaml and libguestfs-ocaml-dev subpackages.
[libguestfs.git] / inspector / Makefile.am
index 69b5683..5c48724 100644 (file)
@@ -33,7 +33,6 @@ EXAMPLE_XML = \
        example-windows-xp-cd.xml
 
 EXTRA_DIST = \
-       run-inspector-locally \
        virt-inspector.pod
 
 CLEANFILES = stamp-virt-inspector.pod
@@ -60,6 +59,7 @@ virt_inspector_SOURCES = \
        virt-inspector.c
 
 virt_inspector_CFLAGS = \
+       -DGUESTFS_WARN_DEPRECATED=1 \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        -I$(top_srcdir)/fish \
        -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
@@ -100,10 +100,19 @@ endif
 # can run them.  Instead you can run them by hand.
 
 example-debian.xml:
-       ./run-inspector-locally ../images/debian.img > $@
+       rm -f $@ $@-t
+       ../run $(builddir)/virt-inspector ../images/debian.img > $@-t
+       mv $@-t $@
 example-fedora.xml:
-       ./run-inspector-locally ../images/fedora.img > $@
+       rm -f $@ $@-t
+       ../run $(builddir)/virt-inspector ../images/fedora.img > $@-t
+       mv $@-t $@
 example-ubuntu.xml:
-       ./run-inspector-locally ../images/ubuntu.img > $@
+       rm -f $@ $@-t
+       ../run $(builddir)/virt-inspector ../images/ubuntu.img > $@-t
+       mv $@-t $@
 example-windows.xml:
-       ./run-inspector-locally ../images/windows.img | fgrep -v '<uuid>' > $@
+       rm -f $@ $@-t
+       ../run $(builddir)/virt-inspector ../images/windows.img | \
+           fgrep -v '<uuid>' > $@-t
+       mv $@-t $@