tests: Rename extratests -> tests/extra.
[libguestfs.git] / images / Makefile.am
index 1cae8bf..e413750 100644 (file)
@@ -39,7 +39,7 @@ EXTRA_DIST = \
        test-grep.txt \
        guest-aux/make-debian-img.sh \
        guest-aux/debian-packages \
-       guest-aux/make-fedora-img.sh \
+       guest-aux/make-fedora-img.pl \
        guest-aux/fedora-name.db.txt \
        guest-aux/fedora-name.db \
        guest-aux/fedora-packages.db.txt \
@@ -56,7 +56,7 @@ noinst_DATA = test.iso
 
 # This is 'check_DATA' because we don't need it until 'make check'
 # time and we need the tools we have built in order to make it.
-check_DATA = debian.img fedora.img ubuntu.img windows.img
+check_DATA = debian.img fedora.img fedora-md1.img fedora-md2.img ubuntu.img windows.img
 
 CLEANFILES = \
        test.iso test.sqsh \
@@ -170,12 +170,22 @@ $(builddir)/test-grep.txt.gz: test-grep.txt
        mv $@-t $@
 
 # Make a (dummy) Fedora image.
-fedora.img: guest-aux/make-fedora-img.sh \
+fedora.img: guest-aux/make-fedora-img.pl \
                guest-aux/fedora-name.db \
                guest-aux/fedora-packages.db
        TMPDIR=$(top_builddir) \
        SRCDIR=$(srcdir) \
-       bash $<
+       LAYOUT=partitions \
+       ../run $<
+
+# Make a (dummy) Fedora image using md devices
+fedora-md1.img fedora-md2.img: guest-aux/make-fedora-img.pl \
+               guest-aux/fedora-name.db \
+               guest-aux/fedora-packages.db
+       TMPDIR=$(top_builddir) \
+       SRCDIR=$(srcdir) \
+       LAYOUT=partitions-md \
+       ../run $<
 
 guest-aux/fedora-name.db: guest-aux/fedora-name.db.txt
        rm -f $@ $@-t