Memoize the output of pod2text function in the generator.
[libguestfs.git] / images / Makefile.am
index 71d63a8..8855382 100644 (file)
@@ -15,7 +15,7 @@
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
-EXTRA_DIST     = \
+EXTRA_DIST = \
        helloworld.tar \
        helloworld.tar.gz \
        mbr-ext2-empty.img.gz \
@@ -23,10 +23,14 @@ EXTRA_DIST  = \
 
 noinst_DATA = test.sqsh
 
-CLEANFILES = test.sqsh
+CLEANFILES = \
+       test.sqsh \
+       100kallzeroes 100kallnewlines 100kallspaces 100krandom 10klines \
+       initrd
 
 squash_files = helloworld.tar helloworld.tar.gz empty known-1 known-2 known-3 \
-       100kallzeroes 100kallnewlines 100kallspaces 100krandom 10klines
+       100kallzeroes 100kallnewlines 100kallspaces 100krandom 10klines \
+       initrd
 
 test.sqsh: $(squash_files)
        rm -f $@
@@ -60,3 +64,8 @@ test.sqsh: $(squash_files)
          i=$$(($$i+1)); \
        done > $@-t
        mv $@-t $@
+
+initrd: empty known-1 known-2 known-3
+       rm -f $@ $@-t
+       for f in $^; do echo $$f; done | cpio -o -H newc | gzip --best > $@-t
+       mv $@-t $@