Add large test files with standard content for the C API test.
[libguestfs.git] / images / Makefile.am
index dcdf51f..46488eb 100644 (file)
@@ -25,8 +25,38 @@ noinst_DATA = test.sqsh
 
 CLEANFILES = test.sqsh
 
-squash_files = helloworld.tar helloworld.tar.gz empty known-1 known-2 known-3
+squash_files = helloworld.tar helloworld.tar.gz empty known-1 known-2 known-3 \
+       100kallzeroes 100kallnewlines 100kallspaces 100krandom 10klines
 
 test.sqsh: $(squash_files)
        rm -f $@
        $(MKSQUASHFS) $(squash_files) $@
+
+100kallzeroes:
+       rm -f $@ $@-t
+       dd if=/dev/zero of=$@-t bs=1024 count=100
+       mv $@-t $@
+
+100kallnewlines: 100kallzeroes
+       rm -f $@ $@-t
+       tr '\0' '\n' < $< > $@-t
+       mv $@-t $@
+
+100kallspaces: 100kallzeroes
+       rm -f $@ $@-t
+       tr '\0' ' ' < $< > $@-t
+       mv $@-t $@
+
+100krandom:
+       rm -f $@ $@-t
+       dd if=/dev/urandom of=$@-t bs=1024 count=100
+       mv $@-t $@
+
+10klines:
+       rm -f $@ $@-t
+       i=0; \
+       while [ $$i -lt 10000 ]; do \
+         echo "abcdefghijklmnopqrstuvwxyz"; \
+         i=$$(($$i+1)); \
+       done > $@-t
+       mv $@-t $@