enable scrub on Debian
[libguestfs.git] / hivex / Makefile.am
index 312cc3c..66c5bf1 100644 (file)
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
-SUBDIRS = tools
-
-EXTRA_DIST = hivex.pod hivexml.pod hivexget.pod hivexsh.pod LICENSE
+SUBDIRS = t tools
+
+EXTRA_DIST = \
+       hivex.pod \
+       hivexml.pod \
+       hivexget.pod \
+       hivexget \
+       hivexsh.pod \
+       LICENSE \
+       example1 \
+       example2 \
+       example3 \
+       example4 \
+       example5 \
+       example6
 
 lib_LTLIBRARIES = libhivex.la
 
@@ -32,6 +44,7 @@ libhivex_la_CPPFLAGS = -I$(top_srcdir)/gnulib/lib
 
 bin_PROGRAMS = hivexml hivexsh
 bin_SCRIPTS = hivexget
+noinst_SCRIPTS = example1 example2 example3 example4 example5 example6
 
 hivexml_SOURCES = \
   hivexml.c
@@ -44,7 +57,9 @@ hivexml_CFLAGS = \
   $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
 hivexsh_SOURCES = \
-  hivexsh.c
+  hivexsh.c \
+  hivex.h \
+  byte_conversions.h
 
 hivexsh_LDADD = libhivex.la ../gnulib/lib/libgnu.la  $(LIBREADLINE)
 hivexsh_CFLAGS = \