enable scrub on Debian
[libguestfs.git] / hivex / Makefile.am
index 1adbbd8..66c5bf1 100644 (file)
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
-EXTRA_DIST = hivex.pod hivexml.pod hivexget.pod hivexsh.pod LICENSE
+SUBDIRS = t tools
+
+EXTRA_DIST = \
+       hivex.pod \
+       hivexml.pod \
+       hivexget.pod \
+       hivexget \
+       hivexsh.pod \
+       LICENSE \
+       example1 \
+       example2 \
+       example3 \
+       example4 \
+       example5 \
+       example6
 
 lib_LTLIBRARIES = libhivex.la
 
@@ -24,17 +38,18 @@ libhivex_la_SOURCES = \
   hivex.h \
   byte_conversions.h
 
-libhivex_la_LDFLAGS = -version-info 0:0:0
-libhivex_la_CFLAGS = \
-  $(WARN_CFLAGS) $(WERROR_CFLAGS)
+libhivex_la_LDFLAGS = -version-info 0:0:0 $(LTLIBINTL) $(LTLIBTHREAD)
+libhivex_la_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
+libhivex_la_CPPFLAGS = -I$(top_srcdir)/gnulib/lib
 
 bin_PROGRAMS = hivexml hivexsh
 bin_SCRIPTS = hivexget
+noinst_SCRIPTS = example1 example2 example3 example4 example5 example6
 
 hivexml_SOURCES = \
   hivexml.c
 
-hivexml_LDADD = libhivex.la $(LIBXML2_LIBS)
+hivexml_LDADD = libhivex.la $(LIBXML2_LIBS) ../gnulib/lib/libgnu.la
 hivexml_CFLAGS = \
   -I$(top_srcdir)/src \
   -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
@@ -42,7 +57,9 @@ hivexml_CFLAGS = \
   $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
 hivexsh_SOURCES = \
-  hivexsh.c
+  hivexsh.c \
+  hivex.h \
+  byte_conversions.h
 
 hivexsh_LDADD = libhivex.la ../gnulib/lib/libgnu.la  $(LIBREADLINE)
 hivexsh_CFLAGS = \