hivex: Add HIVEX_OPEN_WRITE flag to allow hive to be opened for writing.
[libguestfs.git] / hivex / Makefile.am
index 574bcac..312cc3c 100644 (file)
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
-EXTRA_DIST = hivex.pod hivexml.pod hivexget.pod LICENSE
+SUBDIRS = tools
+
+EXTRA_DIST = hivex.pod hivexml.pod hivexget.pod hivexsh.pod LICENSE
 
 lib_LTLIBRARIES = libhivex.la
 
 libhivex_la_SOURCES = \
   hivex.c \
-  hivex.h
+  hivex.h \
+  byte_conversions.h
 
-libhivex_la_LDFLAGS = -version-info 0:0:0
-libhivex_la_CFLAGS = \
-  $(WARN_CFLAGS) $(WERROR_CFLAGS)
+libhivex_la_LDFLAGS = -version-info 0:0:0 $(LTLIBINTL) $(LTLIBTHREAD)
+libhivex_la_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
+libhivex_la_CPPFLAGS = -I$(top_srcdir)/gnulib/lib
 
-bin_PROGRAMS = hivexml hivexget
+bin_PROGRAMS = hivexml hivexsh
+bin_SCRIPTS = hivexget
 
 hivexml_SOURCES = \
   hivexml.c
 
-hivexml_LDADD = libhivex.la $(LIBXML2_LIBS)
+hivexml_LDADD = libhivex.la $(LIBXML2_LIBS) ../gnulib/lib/libgnu.la
 hivexml_CFLAGS = \
+  -I$(top_srcdir)/src \
+  -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
   $(LIBXML2_CFLAGS) \
   $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
-hivexget_SOURCES = \
-  hivexget.c
+hivexsh_SOURCES = \
+  hivexsh.c
 
-hivexget_LDADD = libhivex.la
-hivexget_CFLAGS = \
+hivexsh_LDADD = libhivex.la ../gnulib/lib/libgnu.la  $(LIBREADLINE)
+hivexsh_CFLAGS = \
+  -I$(top_srcdir)/gnulib/lib \
+  -I$(top_srcdir)/src \
+  -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
   $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
-man_MANS = hivex.3 hivexml.1 hivexget.1
+man_MANS = hivex.3 hivexml.1 hivexget.1 hivexsh.1
 
 hivex.3: hivex.pod
        $(POD2MAN) \
@@ -69,3 +78,49 @@ hivexget.1: hivexget.pod
          --name "hivexget" \
          --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
          $< > $@-t; mv $@-t $@
+
+hivexsh.1: hivexsh.pod
+       $(POD2MAN) \
+         --section 1 \
+         -c "Windows Registry" \
+         --name "hivexsh" \
+         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
+         $< > $@-t; mv $@-t $@
+
+noinst_DATA = \
+       $(top_builddir)/html/hivex.3.html \
+       $(top_builddir)/html/hivexml.1.html \
+       $(top_builddir)/html/hivexget.1.html \
+       $(top_builddir)/html/hivexsh.1.html
+
+$(top_builddir)/html/hivex.3.html: hivex.pod
+       mkdir -p $(top_builddir)/html
+       cd $(top_builddir) && pod2html \
+         --css 'pod.css' \
+         --htmldir html \
+         --outfile html/hivex.3.html \
+         hivex/hivex.pod
+
+$(top_builddir)/html/hivexml.1.html: hivexml.pod
+       mkdir -p $(top_builddir)/html
+       cd $(top_builddir) && pod2html \
+         --css 'pod.css' \
+         --htmldir html \
+         --outfile html/hivexml.1.html \
+         hivex/hivexml.pod
+
+$(top_builddir)/html/hivexget.1.html: hivexget.pod
+       mkdir -p $(top_builddir)/html
+       cd $(top_builddir) && pod2html \
+         --css 'pod.css' \
+         --htmldir html \
+         --outfile html/hivexget.1.html \
+         hivex/hivexget.pod
+
+$(top_builddir)/html/hivexsh.1.html: hivexsh.pod
+       mkdir -p $(top_builddir)/html
+       cd $(top_builddir) && pod2html \
+         --css 'pod.css' \
+         --htmldir html \
+         --outfile html/hivexsh.1.html \
+         hivex/hivexsh.pod