generator: Move all library generation code together.
[libguestfs.git] / fuse / Makefile.am
index c041058..5ffdb95 100644 (file)
@@ -15,7 +15,9 @@
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
-EXTRA_DIST = guestmount.pod
+include $(top_srcdir)/subdir-rules.mk
+
+EXTRA_DIST = guestmount.pod test-fuse.sh
 
 if HAVE_FUSE
 
@@ -39,6 +41,8 @@ guestmount_LDADD = \
        $(top_builddir)/src/libguestfs.la \
        ../gnulib/lib/libgnu.la
 
+# Documentation.
+
 man_MANS = guestmount.1
 
 guestmount.1: guestmount.pod
@@ -60,4 +64,10 @@ $(top_builddir)/html/guestmount.1.html: guestmount.pod
          --outfile html/guestmount.1.html \
          fuse/guestmount.pod
 
+# Tests.
+
+TESTS = test-fuse.sh
+TESTS_ENVIRONMENT = \
+       top_builddir=..
+
 endif