out-of-tree build: fix documentation generation
[libguestfs.git] / fuse / Makefile.am
index a122082..10bbc9d 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs
-# Copyright (C) 2009 Red Hat Inc.
+# Copyright (C) 2009-2011 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -19,6 +19,8 @@ include $(top_srcdir)/subdir-rules.mk
 
 EXTRA_DIST = guestmount.pod test-fuse.sh
 
+CLEANFILES = stamp-guestmount.pod
+
 if HAVE_FUSE
 
 bin_PROGRAMS = guestmount
@@ -26,7 +28,9 @@ bin_PROGRAMS = guestmount
 # These source files (all related to option parsing) are shared
 # between guestfish and guestmount.
 SHARED_SOURCE_FILES = \
+       ../fish/config.c \
        ../fish/inspect.c \
+       ../fish/keys.c \
        ../fish/options.h \
        ../fish/options.c \
        ../fish/virt.c
@@ -39,48 +43,34 @@ guestmount_SOURCES = \
        guestmount.h
 
 guestmount_CFLAGS = \
+       -DGUESTFS_WARN_DEPRECATED=1 \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        -I$(top_srcdir)/fish \
        -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
-       -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
        -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
-       $(FUSE_CFLAGS) $(LIBVIRT_CFLAGS) $(LIBXML2_CFLAGS) \
+       $(FUSE_CFLAGS) \
+       $(LIBCONFIG_CFLAGS) \
        $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
 guestmount_LDADD = \
        $(FUSE_LIBS) -lulockmgr \
-       $(LIBVIRT_LIBS) $(LIBXML2_LIBS) \
+       $(LIBCONFIG_LIBS) \
        $(top_builddir)/src/libguestfs.la \
        ../gnulib/lib/libgnu.la
 
-# Build a partly-static library (for the binary distribution).
-
-guestmount.static$(EXEEXT): $(guestmount_OBJECTS) $(guestmount_DEPENDENCIES)
-       $(top_srcdir)/relink-static.sh \
-       $(guestmount_LINK) $(guestmount_OBJECTS) -static $(guestmount_LDADD) $(guestmount_LIBS) -lpcre -lhivex -lmagic -lz
-
 # Documentation.
 
 man_MANS = guestmount.1
+noinst_DATA = $(top_builddir)/html/guestmount.1.html
+
+guestmount.1 $(top_builddir)/html/guestmount.1.html: stamp-guestmount.pod
 
-guestmount.1: guestmount.pod
-       $(POD2MAN) \
-         --section 1 \
-         -c "Virtualization Support" \
-         --name "guestmount" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         $< > $@-t; mv $@-t $@
-
-noinst_DATA = \
-       $(top_builddir)/html/guestmount.1.html
-
-$(top_builddir)/html/guestmount.1.html: guestmount.pod
-       mkdir -p $(top_builddir)/html
-       cd $(top_builddir) && pod2html \
-         --css 'pod.css' \
-         --htmldir html \
-         --outfile html/guestmount.1.html \
-         fuse/guestmount.pod
+stamp-guestmount.pod: guestmount.pod
+       $(top_builddir)/podwrapper.sh \
+         --man guestmount.1 \
+         --html $(top_builddir)/html/guestmount.1.html \
+         $<
+       touch $@
 
 # Tests.