out-of-tree build: fix documentation generation
[libguestfs.git] / fuse / Makefile.am
index 7d3b463..10bbc9d 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs
-# Copyright (C) 2009 Red Hat Inc.
+# Copyright (C) 2009-2011 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -28,6 +28,7 @@ bin_PROGRAMS = guestmount
 # These source files (all related to option parsing) are shared
 # between guestfish and guestmount.
 SHARED_SOURCE_FILES = \
+       ../fish/config.c \
        ../fish/inspect.c \
        ../fish/keys.c \
        ../fish/options.h \
@@ -42,16 +43,18 @@ guestmount_SOURCES = \
        guestmount.h
 
 guestmount_CFLAGS = \
+       -DGUESTFS_WARN_DEPRECATED=1 \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        -I$(top_srcdir)/fish \
        -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
-       -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
        -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
        $(FUSE_CFLAGS) \
+       $(LIBCONFIG_CFLAGS) \
        $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
 guestmount_LDADD = \
        $(FUSE_LIBS) -lulockmgr \
+       $(LIBCONFIG_LIBS) \
        $(top_builddir)/src/libguestfs.la \
        ../gnulib/lib/libgnu.la
 
@@ -63,7 +66,7 @@ noinst_DATA = $(top_builddir)/html/guestmount.1.html
 guestmount.1 $(top_builddir)/html/guestmount.1.html: stamp-guestmount.pod
 
 stamp-guestmount.pod: guestmount.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man guestmount.1 \
          --html $(top_builddir)/html/guestmount.1.html \
          $<