perl: Add documentation about testing availability of methods and features.
[libguestfs.git] / fish / Makefile.am
index 4060f1f..f75e4e0 100644 (file)
@@ -49,8 +49,10 @@ guestfish_SOURCES = \
        man.c \
        more.c \
        prep.c \
+       progress.c \
        rc.c \
        reopen.c \
+       rmsd.h \
        supported.c \
        tilde.c \
        time.c \
@@ -72,7 +74,7 @@ guestfish_CFLAGS = \
 
 guestfish_LDADD = \
        $(LIBVIRT_LIBS) $(LIBXML2_LIBS) \
-       $(top_builddir)/src/libguestfs.la $(LIBREADLINE)
+       $(top_builddir)/src/libguestfs.la $(LIBREADLINE) -lm
 
 # Make libguestfs use the convenience library.
 noinst_LTLIBRARIES = librc_protocol.la
@@ -96,7 +98,7 @@ endif
 
 guestfish.static$(EXEEXT): $(guestfish_OBJECTS) $(guestfish_DEPENDENCIES)
        $(top_srcdir)/relink-static.sh \
-       $(guestfish_LINK) $(guestfish_OBJECTS) -static $(guestfish_LDADD) $(guestfish_LIBS) -lpcre -lhivex -lmagic -lz -lm
+       $(guestfish_LINK) $(guestfish_OBJECTS) -static $(guestfish_LDADD) $(guestfish_LIBS) -ltinfo -lpcre -lhivex -lmagic -lz -lm
 
 # Manual page.
 # guestfish-actions.pod is autogenerated.  There is no include