inspect: Add detection of Pardus.
[libguestfs.git] / fish / Makefile.am
index 4c5d76f..e3221ca 100644 (file)
@@ -23,6 +23,7 @@ generator_built = \
        cmds.c \
        completion.c \
        guestfish-actions.pod \
+       guestfish-commands.pod \
        prepopts.h \
        prepopts.c
 
@@ -37,16 +38,28 @@ EXTRA_DIST = \
        guestfish.pod \
        guestfish-bash-completion.sh
 
+# These source files (all related to option parsing) are shared
+# between guestfish and guestmount.  Keep a convenient list here just
+# so we know which ones are shared.  These files must not include
+# other guestfish files.
+SHARED_SOURCE_FILES = \
+       inspect.c \
+       options.h \
+       options.c \
+       virt.c
+
 guestfish_SOURCES = \
        $(generator_built) \
+       $(SHARED_SOURCE_FILES) \
        alloc.c \
+       copy.c \
        destpaths.c \
        echo.c \
        edit.c \
        fish.c \
        fish.h \
        glob.c \
-       inspect.c \
+       hexedit.c \
        lcd.c \
        man.c \
        more.c \
@@ -62,8 +75,7 @@ guestfish_SOURCES = \
        rmsd.h \
        supported.c \
        tilde.c \
-       time.c \
-       virt.c
+       time.c
 
 # This convenience library is solely to avoid compiler warnings
 # in its generated sources.
@@ -108,14 +120,15 @@ guestfish.static$(EXEEXT): $(guestfish_OBJECTS) $(guestfish_DEPENDENCIES)
        $(guestfish_LINK) $(guestfish_OBJECTS) -static $(guestfish_LDADD) $(guestfish_LIBS) -ltinfo -lpcre -lhivex -lmagic -lz -lm
 
 # Manual page.
-# guestfish-actions.pod is autogenerated.  There is no include
-# mechanism for POD, so we have to do it by hand.
+# guestfish-actions.pod and guestfish-commands.pod are autogenerated.
+# There is no include mechanism for POD, so we have to do it by hand.
 
 man_MANS = guestfish.1
 
-guestfish.1: guestfish.pod guestfish-actions.pod
+guestfish.1: guestfish.pod guestfish-actions.pod guestfish-commands.pod
        sed \
          -e '/@ACTIONS@/rguestfish-actions.pod' -e 's/@ACTIONS@//' \
+         -e '/@FISH_COMMANDS@/rguestfish-commands.pod' -e 's/@FISH_COMMANDS@//' \
          < $< | \
        $(POD2MAN) \
          --section 1 \