fish: First pass at guestfish bash completion script.
[libguestfs.git] / fish / Makefile.am
index 795952a..bdb1acb 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs
-# Copyright (C) 2009 Red Hat Inc.
+# Copyright (C) 2009-2010 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -21,7 +21,8 @@ bin_PROGRAMS = guestfish
 
 generator_built = \
        cmds.c \
-       completion.c
+       completion.c \
+       guestfish-actions.pod
 
 BUILT_SOURCES = \
        $(generator_built) \
@@ -30,7 +31,8 @@ BUILT_SOURCES = \
 
 EXTRA_DIST = \
        $(BUILT_SOURCES) \
-       rc_protocol.x
+       rc_protocol.x \
+       guestfish.pod
 
 guestfish_SOURCES = \
        $(generator_built) \
@@ -42,9 +44,12 @@ guestfish_SOURCES = \
        fish.h \
        glob.c \
        lcd.c \
+       man.c \
        more.c \
+       prep.c \
        rc.c \
        reopen.c \
+       supported.c \
        tilde.c \
        time.c
 
@@ -57,6 +62,7 @@ guestfish_CFLAGS = \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        -I$(top_srcdir)/fish -I$(top_builddir)/fish \
        -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
+       -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
        -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
        $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
@@ -79,3 +85,25 @@ rc_protocol.h: rc_protocol.x
        $(RPCGEN) -h -o $@-t $<
        mv $@-t $@
 endif
+
+# Manual page.
+# guestfish-actions.pod is autogenerated.  There is no include
+# mechanism for POD, so we have to do it by hand.
+
+man_MANS = guestfish.1
+
+guestfish.1: guestfish.pod guestfish-actions.pod
+       sed \
+         -e '/@ACTIONS@/rguestfish-actions.pod' -e 's/@ACTIONS@//' \
+         < $< | \
+       $(POD2MAN) \
+         --section 1 \
+         -c "Virtualization Support" \
+         --name "guestfish" \
+         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
+         > $@
+
+# Bash completion script.
+
+bashcompletiondir = $(sysconfdir)/bash_completion.d
+bashcompletion_DATA = guestfish-bash-completion.sh