Fix networking in the appliance.
[libguestfs.git] / fish / Makefile.am
index 4c5d76f..91094df 100644 (file)
@@ -23,6 +23,7 @@ generator_built = \
        cmds.c \
        completion.c \
        guestfish-actions.pod \
+       guestfish-commands.pod \
        prepopts.h \
        prepopts.c
 
@@ -40,12 +41,14 @@ EXTRA_DIST = \
 guestfish_SOURCES = \
        $(generator_built) \
        alloc.c \
+       copy.c \
        destpaths.c \
        echo.c \
        edit.c \
        fish.c \
        fish.h \
        glob.c \
+       hexedit.c \
        inspect.c \
        lcd.c \
        man.c \
@@ -108,14 +111,15 @@ guestfish.static$(EXEEXT): $(guestfish_OBJECTS) $(guestfish_DEPENDENCIES)
        $(guestfish_LINK) $(guestfish_OBJECTS) -static $(guestfish_LDADD) $(guestfish_LIBS) -ltinfo -lpcre -lhivex -lmagic -lz -lm
 
 # Manual page.
-# guestfish-actions.pod is autogenerated.  There is no include
-# mechanism for POD, so we have to do it by hand.
+# guestfish-actions.pod and guestfish-commands.pod are autogenerated.
+# There is no include mechanism for POD, so we have to do it by hand.
 
 man_MANS = guestfish.1
 
-guestfish.1: guestfish.pod guestfish-actions.pod
+guestfish.1: guestfish.pod guestfish-actions.pod guestfish-commands.pod
        sed \
          -e '/@ACTIONS@/rguestfish-actions.pod' -e 's/@ACTIONS@//' \
+         -e '/@FISH_COMMANDS@/rguestfish-commands.pod' -e 's/@FISH_COMMANDS@//' \
          < $< | \
        $(POD2MAN) \
          --section 1 \