avoid compiler warnings about unused vars in generated code
[libguestfs.git] / fish / Makefile.am
index 1e5b108..5bf3fbd 100644 (file)
 
 bin_PROGRAMS = guestfish
 
+EXTRA_DIST = \
+       rc_protocol.x
+
+CLEANFILES = rc_protocol.c rc_protocol.h
+
 guestfish_SOURCES = \
        alloc.c \
        cmds.c \
@@ -27,9 +32,44 @@ guestfish_SOURCES = \
        fish.c \
        fish.h \
        glob.c \
-       lcd.c
+       lcd.c \
+       more.c \
+       rc.c \
+       reopen.c \
+       tilde.c \
+       time.c
+
+# This convenience library is solely to avoid compiler warnings
+# in its generated sources.
+librc_protocol_la_SOURCES = rc_protocol.c
+librc_protocol_la_CFLAGS = -Wall -Wno-unused
+
+BUILT_SOURCES = \
+       rc_protocol.c \
+       rc_protocol.h
 
 guestfish_CFLAGS = \
-       -I$(top_builddir)/src -Wall \
+       -I$(top_srcdir)/src -I$(top_builddir)/src \
+       -I$(top_srcdir)/fish -I$(top_builddir)/fish \
+       -Wall \
        -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"'
+
 guestfish_LDADD = $(top_builddir)/src/libguestfs.la $(LIBREADLINE)
+
+# Make libguestfs use the convenience library.
+noinst_LTLIBRARIES = librc_protocol.la
+guestfish_LDADD += librc_protocol.la
+
+if HAVE_RPCGEN
+rc_protocol.c: rc_protocol.x
+       rm -f $@-t $@-t2
+       $(RPCGEN) -c -o $@-t $<
+       sed 's,\.\./\.\./fish/,,' < $@-t > $@-t2
+       rm $@-t
+       mv $@-t2 $@
+
+rc_protocol.h: rc_protocol.x
+       rm -f $@-t
+       $(RPCGEN) -h -o $@-t $<
+       mv $@-t $@
+endif