Documentation updates.
[libguestfs.git] / fish / Makefile.am
index 795952a..43dce00 100644 (file)
@@ -21,7 +21,8 @@ bin_PROGRAMS = guestfish
 
 generator_built = \
        cmds.c \
-       completion.c
+       completion.c \
+       guestfish-actions.pod
 
 BUILT_SOURCES = \
        $(generator_built) \
@@ -30,7 +31,8 @@ BUILT_SOURCES = \
 
 EXTRA_DIST = \
        $(BUILT_SOURCES) \
-       rc_protocol.x
+       rc_protocol.x \
+       guestfish.pod
 
 guestfish_SOURCES = \
        $(generator_built) \
@@ -57,6 +59,7 @@ guestfish_CFLAGS = \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        -I$(top_srcdir)/fish -I$(top_builddir)/fish \
        -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
+       -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
        -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
        $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
@@ -79,3 +82,20 @@ rc_protocol.h: rc_protocol.x
        $(RPCGEN) -h -o $@-t $<
        mv $@-t $@
 endif
+
+# Manual page.
+# guestfish-actions.pod is autogenerated.  There is no include
+# mechanism for POD, so we have to do it by hand.
+
+man_MANS = guestfish.1
+
+guestfish.1: guestfish.pod guestfish-actions.pod
+       sed \
+         -e '/@ACTIONS@/rguestfish-actions.pod' -e 's/@ACTIONS@//' \
+         < $< | \
+       $(POD2MAN) \
+         --section 1 \
+         -c "Virtualization Support" \
+         --name "guestfish" \
+         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
+         > $@