fish: Add fish-cmds.h to generator_built.
[libguestfs.git] / fish / Makefile.am
index 22aaf4c..4215784 100644 (file)
@@ -30,6 +30,7 @@ generator_built = \
        cmds.c \
        cmds_gperf.gperf \
        completion.c \
        cmds.c \
        cmds_gperf.gperf \
        completion.c \
+       fish-cmds.h \
        guestfish-actions.pod \
        guestfish-commands.pod \
        prepopts.h \
        guestfish-actions.pod \
        guestfish-commands.pod \
        prepopts.h \
@@ -170,18 +171,18 @@ noinst_DATA = \
 guestfish.1 $(top_builddir)/html/guestfish.1.html: stamp-guestfish.pod
 
 stamp-guestfish.pod: guestfish.pod guestfish-actions.pod guestfish-commands.pod
 guestfish.1 $(top_builddir)/html/guestfish.1.html: stamp-guestfish.pod
 
 stamp-guestfish.pod: guestfish.pod guestfish-actions.pod guestfish-commands.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man guestfish.1 \
          --html $(top_builddir)/html/guestfish.1.html \
          --man guestfish.1 \
          --html $(top_builddir)/html/guestfish.1.html \
-         --insert guestfish-actions.pod:@ACTIONS@ \
-         --insert guestfish-commands.pod:@FISH_COMMANDS@ \
+         --insert $(srcdir)/guestfish-actions.pod:@ACTIONS@ \
+         --insert $(srcdir)/guestfish-commands.pod:@FISH_COMMANDS@ \
          $<
        touch $@
 
 virt-copy-in.1 $(top_builddir)/html/virt-copy-in.1.html: stamp-virt-copy-in.pod
 
 stamp-virt-copy-in.pod: virt-copy-in.pod
          $<
        touch $@
 
 virt-copy-in.1 $(top_builddir)/html/virt-copy-in.1.html: stamp-virt-copy-in.pod
 
 stamp-virt-copy-in.pod: virt-copy-in.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man virt-copy-in.1 \
          --html $(top_builddir)/html/virt-copy-in.1.html \
          $<
          --man virt-copy-in.1 \
          --html $(top_builddir)/html/virt-copy-in.1.html \
          $<
@@ -190,7 +191,7 @@ stamp-virt-copy-in.pod: virt-copy-in.pod
 virt-copy-out.1 $(top_builddir)/html/virt-copy-out.1.html: stamp-virt-copy-out.pod
 
 stamp-virt-copy-out.pod: virt-copy-out.pod
 virt-copy-out.1 $(top_builddir)/html/virt-copy-out.1.html: stamp-virt-copy-out.pod
 
 stamp-virt-copy-out.pod: virt-copy-out.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man virt-copy-out.1 \
          --html $(top_builddir)/html/virt-copy-out.1.html \
          $<
          --man virt-copy-out.1 \
          --html $(top_builddir)/html/virt-copy-out.1.html \
          $<
@@ -199,7 +200,7 @@ stamp-virt-copy-out.pod: virt-copy-out.pod
 virt-tar-in.1 $(top_builddir)/html/virt-tar-in.1.html: stamp-virt-tar-in.pod
 
 stamp-virt-tar-in.pod: virt-tar-in.pod
 virt-tar-in.1 $(top_builddir)/html/virt-tar-in.1.html: stamp-virt-tar-in.pod
 
 stamp-virt-tar-in.pod: virt-tar-in.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man virt-tar-in.1 \
          --html $(top_builddir)/html/virt-tar-in.1.html \
          $<
          --man virt-tar-in.1 \
          --html $(top_builddir)/html/virt-tar-in.1.html \
          $<
@@ -208,7 +209,7 @@ stamp-virt-tar-in.pod: virt-tar-in.pod
 virt-tar-out.1 $(top_builddir)/html/virt-tar-out.1.html: stamp-virt-tar-out.pod
 
 stamp-virt-tar-out.pod: virt-tar-out.pod
 virt-tar-out.1 $(top_builddir)/html/virt-tar-out.1.html: stamp-virt-tar-out.pod
 
 stamp-virt-tar-out.pod: virt-tar-out.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man virt-tar-out.1 \
          --html $(top_builddir)/html/virt-tar-out.1.html \
          $<
          --man virt-tar-out.1 \
          --html $(top_builddir)/html/virt-tar-out.1.html \
          $<